tried taking the I've tried taking the battery out I've tried the 20 seconds thing and still get just a back light flash twic

Oct 29, 2018
2
0
10
0
I don't know why it's not charging it's a Galaxy Tab 1 and I've did the 20 seconds button thing I've done that take the battery out put it back in thing and nothing's working what do I do oh yeah that's been sitting for almost a year now without being used
 
Thread starter Similar threads Forum Replies Date
J Android Tablets 6
2 Android Tablets 1
M Android Tablets 1
S Android Tablets 1
S Android Tablets 3
A Android Tablets 1
A Android Tablets 1
L Android Tablets 1
J Android Tablets 1
S Android Tablets 1
R Android Tablets 1
B Android Tablets 1
L Android Tablets 1
Y Android Tablets 1
J Android Tablets 1
O Android Tablets 1
D Android Tablets 1
L Android Tablets 1
S Android Tablets 1
C Android Tablets 1
Similar threads
Question New Android Tablet, 500GB available storage, can only add 10GB, won't take any more
My rca tablet is not working when I hold the power button and the volume down it doesn't take me anywhere
My pin screen comes on but wont take my pin
Solved! I have a RCA Galileo Pro and I had done a factory reset on the tablet so that I can restart it and take the old Gmail account
My Samsung Galaxy tab 4 connects to my wifi at home but when I take it other places it won't connect to WiFi, what is going wr
Solved! how do i take off my password off of my phone if the option none issnt available
How do i stop my tablet taking old inbox emails off after a period of time. I will do this yselv
The pictures I take on my rca tablet are a orangeish color an blurry how can I fix that
Hi, I have RCA,Galileo Pro,was having having issues with freezing up alot,so I did a factory reset ,now it won't take my wifi
Can't take sd card out
Where is the keyboard on a rca tablet when you take it apart
my 32 GB still won't take stuffs, could it be that I've erased some valuable default apps which can help in getting my d
I bought my 6 year olds boys tablets for the bday crca Voyager tablets list receipt with activation code Walmart want take bac
My tablet when plunged in says 100% when I take the charger off its says 4% but when plugged works just fine .I'm on it now .
Why does my tablet take so long to startup
battery on insignia tablet will not take charge
on my tablet popped up firmware update and they can't come down what should I do and how do I take it down
How can i sign in if it does not take my pass woord
How long does a hard reset take
how do i take a battery out of a tablet?

ASK THE COMMUNITY

TRENDING THREADS