USB headset g941yy problem. Seeking guidance

Colouratura

Commendable
Oct 24, 2016
2
0
1,510
0
Hi there,

I'm kinda desperate and this is my first time asking for help here. I hope anyone can help me.

I'll say right now that exchanging it is not an option for me, neither is refunding it or getting a new one. I'll be grateful for any help.

I'm expiriencing an unusual problem with my Somic g941yy headset. Problem being is that it's not detected by my PC as a device at all. It's not hidden, it's not an unnknown device - it's just not detected as one at all.

Meanwhile it's still getting power, LEDs light up, vibro when turned off-on will do it's little "bzzz". Microphone doesn't light up, even though it supposedly should. And, obviously, there's no sound.

I tried all the basic stuff, looking through the device manager, tried to find it in regedit (though I didn't. Either because it just wasn't there or because I'm bad at it.), multiple USB ports, multiple PCs with different OS (and a laptop + phone), same problem on all of them. Tried running it on OS Win 7 to 10, no difference.

However headset DID work just fine for about 5 minutes after it arrived and I connected it. After I plugged it in I got lazy and ran Driver Pack Solution to get my drivers and must have programs (it was fresh win10 install), after which headset didn't work anymore. I didn't get to install headset's drivers at first, becaused it worked without them just fine, so I decided to do that later. "Later" came when the problem occured, but installation program says that the device isn't connected.

I'm inclined to believe that the problem is in the headset itself, but I may've caused it by updating my drivers somehow.

I do have a video (win 10, now back to win8), but It's of little use, since I described everything here.

[video="https://www.youtube.com/watch?v=lJLPLlN0kas&feature=youtu.be"][/video]

If I forgot any crutial info please feel free to ask. I'm up to solving the problem either via manipulations with my PC or by taking the headset apart, if someone has any recommendations as to what to do after that (I'll learn if I have to).

As I said, I'm really desperate and will try anything I didn't try before. And a big thank you for all who read that in advance, I'll take any help I can get.
 

hang-the-9

Titan
Moderator


You did not say that you tried it on different computers, and this"After I plugged it in I got lazy and ran Driver Pack Solution to get my drivers" sure made it seem like you did not use the correct drivers for the system or the headset.

If you tried different OS, with drivers from the vendor for the headset, and on different computers, headset being bad is pretty much the only thing left.
 

hang-the-9

Titan
Moderator
Test the headset on another system, don't use any 3rd party driver finder. If the headset comes with drivers on disk or from the support site, use those drivers. If they work fine, either uninstall whatever that driver finder installed or go back to a system restore point before you ran it and try the setup again properly.
 

Colouratura

Commendable
Oct 24, 2016
2
0
1,510
0


I think I meantioned in the post that I tried all of that - changed my system completely twice (I did install everything I need manually those two times) and tried a couple of other PCs. Makes me think something wrong with the headset itself, though it's insides seem to be in order (might be wrong on that one).

Also, that driver finder didn't install everything that was related to the headset or usb controller, I was monitoring it during installation. But I DID try to rollback usb controller drivers just in case, it didn't help. Sorry, but answer with template actions like that won't work for this. Still, thank you.

Starting to think there's no soultion for this.
 

hang-the-9

Titan
Moderator


You did not say that you tried it on different computers, and this"After I plugged it in I got lazy and ran Driver Pack Solution to get my drivers" sure made it seem like you did not use the correct drivers for the system or the headset.

If you tried different OS, with drivers from the vendor for the headset, and on different computers, headset being bad is pretty much the only thing left.
 
Thread starter Similar threads Forum Replies Date
MattC231 Audio 0
EnDy_S Audio 0
T Audio 0
Sniipe Audio 0
Captain Kino Audio 0
maveick Audio 4
E Audio 4
S Audio 3
M Audio 1
L Audio 0
Spark3 Audio 1
J Audio 2
A Audio 1
G Audio 1
M Audio 0
M Audio 0
G Audio 0
iman36938 Audio 0
jdip13 Audio 1
G Audio 0

ASK THE COMMUNITY