USB Ports detected in device manager, but do not work or power any usb devices

liquidmettle

Commendable
Dec 17, 2016
1
0
1,510
0
Hello Everyone,

I have the MSI GS70 (purchased in 2014). Recently I had to send my unit in for RMA because several keys on the keyboard had/were failing, and the screen had to be used at about a 120 degree angle because of the connection ended up being loose/failing to the mobo.

Initially the laptop was sent to MSI for the keyboard replacement, and then to XoticPC for the screen repair/replacement.

I received my PC back yesterday and both things that needed to be repaired work flawlessly.

But now none of my USB ports appear to work. They are listed in the Device Manager, uninstalling and reinstalling them through the device manager effected no change, and performing an EC reset effected no change. I've tried multiple USB peripherals (mouse, flashdrives, etc.) and received nothing.

The Flashdrives with lights didn't light up at all leading me to believe that the USB ports are recognized by the system, but are receiving no power.

Any thoughts on what I might try to get these working prior to needing another RMA?
 
If you uninstalled the "USB Host Controller(s)" listed in "Device Manager" and reinstalled them, with no change, then I would try this and see if it helps.

The techs that worked on it may have change the setting for "USB selective suspend". Try this and see if it fixes it.

1. Go to "Control Panel" and then "Power Options".
2. Click on the "Change plan settings" link next to the plan you are using.
3. Next click the "Change advanced power settings".
4. In this new window locate and click to open the "USB settings" and then the "USB selective suspend setting".
5. Make sure the setting is set to "Disable".
6. Now click "Apply", then click "OK" and close out of all the windows you opened.
 
If you uninstalled the "USB Host Controller(s)" listed in "Device Manager" and reinstalled them, with no change, then I would try this and see if it helps.

The techs that worked on it may have change the setting for "USB selective suspend". Try this and see if it fixes it.

1. Go to "Control Panel" and then "Power Options".
2. Click on the "Change plan settings" link next to the plan you are using.
3. Next click the "Change advanced power settings".
4. In this new window locate and click to open the "USB settings" and then the "USB selective suspend setting".
5. Make sure the setting is set to "Disable".
6. Now click "Apply", then click "OK" and close out of all the windows you opened.
 
Thread starter Similar threads Forum Replies Date
ricndraaa Laptop Tech Support 1
Z Laptop Tech Support 0
thy unsung hero Laptop Tech Support 1
Capturis Laptop Tech Support 0
M Laptop Tech Support 1
Mylaptopbrokie Laptop Tech Support 0
Kholens Laptop Tech Support 3
C Laptop Tech Support 0
G Laptop Tech Support 9
R Laptop Tech Support 0
Antunes_Tiago Laptop Tech Support 0
R Laptop Tech Support 1
B Laptop Tech Support 2
S Laptop Tech Support 2
lucasblack29 Laptop Tech Support 1
B Laptop Tech Support 5
I Laptop Tech Support 13
S Laptop Tech Support 3
I Laptop Tech Support 2
C Laptop Tech Support 1

ASK THE COMMUNITY