video_dxgkrnl_fatal_error windows 10 intel hd graphics

ddr250

Commendable
Apr 14, 2016
3
0
1,510
0
Hello,
Hello,
recently I bought a new laptop Acer Aspire E5-532G-P3CE (a month ago).

Laptop spec:
CPU:Intel Pentium Quad core n3700 (up to 2.4 GHz)
GPU:Nvidia geforce 920m 2gb
RAM:8gb DDR3
HDD:1000gb
OS:Windows 10 64-bit

This laptop has 2 GPUs:
GeForce 920m 2gb and
Intel HD Graphics

I played a few games (Minecraft, GTA V, cities skylines, NFS MW 2012, Project cars, Portal 2, Fallout 4, CS:GO and Dead Space 3)

In the beginning there was a lot of lag, because default GPU while playing games was set to Intel HD Graphics.
I open Nvidia control panel and set as default GPU Geforce 920m while playing game.
When i was on the internet or the desktop doing something, not playing games, i used Intel HD, but when playing game, i used Geforce 920m.

Оne day when the laptop wakes up, it crashed with BSOD video_dxgkrnl_fatal_error.
Then the laptop restart and i thought it was something random and will not be repeated.
But then i was in YouTube and watching video, it again crash with the same error message.
That happened like 5-6 times in 5 days. I can work on the laptop, but it is very annoying.
I read about this and i try to reinstall the Drivers for the GPUs (Intel HD and Geforce), but that didnt help. I think that is caused from the Intel HD GPU.

If someone wants dmp crash files, I have them and I can send them.

PS:Sorry for the bad language.

If someone can help to fix this error im going to be very happy!

 
Hi,

Please do try doing a clean install of the graphics card driver that may do the trick.
- Go to Device Manager and uninstall the Nvidia graphics driver.
- Next is to open Programs and Features then uninstall anything related to Nvidia.
- Once done, download and install the latest driver.
- Here's the link: http://www.nvidia.com/Download/index.aspx
- Reboot the laptop once the latest driver has been installed.
- After the reboot do set Nvidia as the default GPU.
- Here's how: http://nvidia.custhelp.com/app/answers/detail/a_id/2615/~/how-do-i-customize-optimus-profiles-and-settings%3F
 
Hi,

Please do try doing a clean install of the graphics card driver that may do the trick.
- Go to Device Manager and uninstall the Nvidia graphics driver.
- Next is to open Programs and Features then uninstall anything related to Nvidia.
- Once done, download and install the latest driver.
- Here's the link: http://www.nvidia.com/Download/index.aspx
- Reboot the laptop once the latest driver has been installed.
- After the reboot do set Nvidia as the default GPU.
- Here's how: http://nvidia.custhelp.com/app/answers/detail/a_id/2615/~/how-do-i-customize-optimus-profiles-and-settings%3F
 

ddr250

Commendable
Apr 14, 2016
3
0
1,510
0

Thanks, bro! I will try this out as soon as possible, and I will tell you is this works or not! ;)

 

ddr250

Commendable
Apr 14, 2016
3
0
1,510
0

It worked, thanks so much for your time and one final question, is there any way that I can use and Intel HD Graphics as well as the Nvidia? If you dont have time, don't worry, I can live without Intel HD Graphics! :)
 
Thread starter Similar threads Forum Replies Date
P Laptop Tech Support 1
A Laptop Tech Support 1
H Laptop Tech Support 1
D Laptop Tech Support 0
stanloona Laptop Tech Support 1
S Laptop Tech Support 3
R Laptop Tech Support 4
K-kurt Laptop Tech Support 0
R Laptop Tech Support 2
M Laptop Tech Support 0
king-slim Laptop Tech Support 4
Y Laptop Tech Support 2
S Laptop Tech Support 3
I Laptop Tech Support 0
M Laptop Tech Support 0
M Laptop Tech Support 1
K Laptop Tech Support 6
L Laptop Tech Support 1
K Laptop Tech Support 4
L Laptop Tech Support 6

ASK THE COMMUNITY