Why is my external graphics card (Laptop) not working properly or to it's full potential?

Okakmetito

Prominent
Apr 30, 2017
8
0
510
0
Hello, I have a laptop (Sony Vaio PCG 71211m) and my in built graphics card is an AMD Mobility Radeon 5000 and it was really bad for running For Honor, even at 144p.
I got an external graphics card connected to the mini PCI-e slot with the (V8.0 EXP GDC Laptop External Independent Video Card for Beast Dock Mini PCI-E) in my laptop. This card is the Asus NVidia GeForce GTX 660 Ti. For Honor says that my new graphics card should be able to run For Honor at 30fps, 720p but when I run it on minimum, medium and even high settings they ALL average out to about 15fps.
Also, the in built graphics card (AMD Radeon Mobility 5000 Series) is still running and even if I disable it from Device Manager it still runs.
I think that if I can completely disable the in built graphics card the computer will only rely on the Asus GTX 660 Ti and hopefully my framerate will increase.
I can't play multiplayer and I'm getting pretty frustrated at this whole situation.

Thanks-
Alexander

Oh and I have already tried to disable it from my BIOS but my version of BIOS is too old and it doesn't give me the option to disable a GPU.

OS: Windows 10 64-bit
CPU: Four of: Intel Core i3 CPU M350 @2.27GHz (quad core)
In built GPU: AMD Mobility Radeon HD 5000 Series
External GPU: (Asus) NVidia GeForce 660 Ti
 

nvincent_08

Commendable
Jun 21, 2016
122
0
1,710
33
i think your cpu is bottlenecking, it is only a 2.2 ghz and for real there is no quad core i3, it is only because hyperthreading it shows 4 cores aka the virtual core, and it is useless to use 660 ti if you have such bad processor, the result would still be bad. i suggest you to get new laptop or build a desktop
 

Okakmetito

Prominent
Apr 30, 2017
8
0
510
0


Don't worry I got it working. The problem was that the graphics card needed to be connected to an external monitor (I used the TV through the HDMI port) and then the game works at 50-60 fps on low settings. Only problem now is that the game and the whole computer crashes every 10 mins when the game is open. Not sure what's happening there but the rest is ok.

 

nvincent_08

Commendable
Jun 21, 2016
122
0
1,710
33


it is actually not a really good idea to use tv as main display for gaming, because some of them have worse response time, input lag, refresh rate(note that high refresh rate on tv is different from computer monitor, they usually have lower refresh rate compared to normal computer monitor), etc. but it is your own needs/option, so i cant force you, i only say the reason why it is bad. check software updates or other things, maybe it will fix the crash problem, or maybe look for info in google, there should be a bunch info about it
 

Okakmetito

Prominent
Apr 30, 2017
8
0
510
0



Thanks
 

Okakmetito

Prominent
Apr 30, 2017
8
0
510
0
So I basically just connected my graphics card to the TV via HDMI and my game works at 60fps (average) on low settings. The TV crashes a lot though so I am waiting for a DVI-D to HDMI cable to arrive because I think that my HDMI port isn't working properly.

So if you have this problem, you NEED an external monitor or TV as it will not work on the laptop screen.

If anyone does have a solution to having it display on the laptop screen, please write it here as I would be interested to know.


This is an example I found on the internet

Hope this helps.
 

nvincent_08

Commendable
Jun 21, 2016
122
0
1,710
33
i think converter not a really good thing tho to use, but it depends, sometimes some of them were bad and messing up a bit. but however using external display is the best optimum way to get better experience, because sometimes the fps could be lower if you use laptop display or sometimes its not smooth. btw have you solved your problem? ask me if you need some more help:)
 

Okakmetito

Prominent
Apr 30, 2017
8
0
510
0


Thanks for helping but it still isn't working! I've tried every cable in the house, 3 HDMI cables and 1 DVI-D to HDMI and the screen still crashes when I start to play the game! I have tried updating every imaginable driver including audio drivers. I really don't know what to do! I know it's not the temp either as I have MSI Afterburner and the card is nice and cool. It isn't dust because it's exposed and I can see no dust. Can you think of any other possible thing I could do to?
 

Okakmetito

Prominent
Apr 30, 2017
8
0
510
0
Ok, that problem is fixed as well. It was my Graphics Card that was crashing and the solution was to install MSI Afterburner and turn down the GPU Core Clock to about -150. After the new For Honor update I had to turn it down to -400 but there is no visible difference in framerate and it runs smoothly. Hopefully anyone with the same problem as me will know know what to do.


Thanks for the help nvincent!

-Alexander
 

Okakmetito

Prominent
Apr 30, 2017
8
0
510
0


Ok it has been a while, but I finally have the proper solution that DOESN'T involve downclocking.

Turns out my PSU was absolute crap. I bought it from china for £16 and it said 500w but it probably couldn't reach 50.

I had to but an Evga 420w PSU and I could overclock to +170 without crashing (although any more and the game itself crashes :/). Then it was working great for 1v1 but 4v4 gamemodes still had low framerates. Then I realised that is was a problem with my CPU bottlenecking. I couldn't overclock that as my system didn't allow me to, but I found a way to make it work faster.


When I run For Honor, I open Task Manager (Control+alt+delete) and go to Details in the top bar. Then right click on forhonor.exe and then click on Set Affinity. If it has only a few cores checked, then I check them all (so click on ALL CORES). After I do that, I right click on the file again and click right on top of set affinity, to Set Priority.

Here it will say that the priority of my game is set to normal. I set it to RealTime for maximum results (or High if I have another program open that takes up my CPU). I have to do this every time I statup the game (which is annoying) but it drastically improves performance.



I keep MSI Afterburner open throughout the game but I close Task Manager once I have set the priority to RealTime.

Also I disable Anti-Viruses if I am not planning on using the internet for browsing or downloading, but just for playing.


Hope this helps, as it is what I do every time I play For Honor.


 
Thread starter Similar threads Forum Replies Date
V Laptop Tech Support 1
T Laptop Tech Support 1
K Laptop Tech Support 1
V Laptop Tech Support 8
M Laptop Tech Support 4
C Laptop Tech Support 1
R Laptop Tech Support 2
R Laptop Tech Support 1
M Laptop Tech Support 6
A Laptop Tech Support 1
E Laptop Tech Support 2
0 Laptop Tech Support 10
H Laptop Tech Support 2
W Laptop Tech Support 2
G Laptop Tech Support 1
D Laptop Tech Support 4
O Laptop Tech Support 2
K Laptop Tech Support 2
A Laptop Tech Support 1
D Laptop Tech Support 1

ASK THE COMMUNITY