Wi-fi, audio, USB not working on Asus X202E

TomazLemos

Commendable
Sep 26, 2016
2
0
1,510
0
Hi there, it's my first time posting here but I've read and learned a lot from this forum, so thank you all very much in advance!

I'm trying to repair a friend's Asus X202E notebook. It worked normally until it got stuck in the blue screen during startup, and wouldn't complete booting. Someone formated the HDD (including the recovery partition) and installed W8.1, which worked but with no sound or internet (wireless or cable). The device manager doesn't show these devices at all. One USB port doesn't work either.

I first thought it was a driver issue, but couldn't make it work. After many attempts I decided to try a W10 clean install, which is installed now, but the symptoms remain the same. I can access the internet through a USB wifi dongle.

I've tried:

- Using Windows troubleshooter;
- Downloading and installing many drivers from the Asus site, for many components (besides audio and internet cards);
- Downloading a X202E drivers compendium some good soul posted here in this forum;
- Using DriverEasy;
- Installing the audio card as legacy in device manager;
- Reseatting wi-fi card;
- Checking the logic board for damage (not good at this, but it looked alright);
- (Going to update as I remember more steps I tried)

I really really don't want to give up on this, but I'm running out of ideas but to say the logic board is fried...

I'd really appreciate your assistance in this matter, thank you all!
 

TomazLemos

Commendable
Sep 26, 2016
2
0
1,510
0
Summarizing the situation so far:

The full model of the notebook is Asus S200E - ct252h - X202E

It had a persistent blue screen during boot which desapeared after a fresh install. After that, no wi-fi, no ethernet, no audio, no USB 3.0, on both W8.1 and W10.

I have tested: ASUS driver update, Intel driver update, DriverEasy, many original X202E ASUS drivers. Neither Audio or Network devices appear on device manager.

Can it still be a driver issue? Would it be a device by device driver solution, or could there be a chipset driver that would "unlock" the devices?

If not a driver issue, what else could it be?
 
Thread starter Similar threads Forum Replies Date
M Laptop Tech Support 7
M Laptop Tech Support 0
B Laptop Tech Support 1
mathiasjrg Laptop Tech Support 1
P Laptop Tech Support 1
R Laptop Tech Support 2
V Laptop Tech Support 5
T Laptop Tech Support 1
S Laptop Tech Support 1
A Laptop Tech Support 1
aforce66 Laptop Tech Support 2
S Laptop Tech Support 1
S Laptop Tech Support 1
B Laptop Tech Support 5
Z Laptop Tech Support 1
K Laptop Tech Support 5
J Laptop Tech Support 1
J Laptop Tech Support 11
C Laptop Tech Support 1
V Laptop Tech Support 4

ASK THE COMMUNITY