Windows 10 thinks my new headphones are speakers?

Status
Not open for further replies.

thategghead

Prominent
Dec 29, 2017
4
0
510
0
I just bought a new pair of 3.5 mm headphones because my old ones broke and I noticed something was off with the audio, so I checked playback devices and my headphones don't show up, but rather as "Speakers". However the speakers and headphones don't play at the same time, just the headphones. When unplugging the headphones and disabling the internal speakers, I noticed that I also can't hear my headphones too.

Is there any way to fix this? It's driving me crazy and surround sound doesn't work (I did a left/right test and I could hear the left sound on the right ear and vise versa and this doesn't happen on my macbook)

I tried restarting my computer, updating my drivers and checking everywhere on the internet but nothing seems to work

Any help will be appreciated
 

The Paladin

Estimable
Herald
https://esupport.sony.com/US/p/model-home.pl?mdl=MDRZX310AP&template_id=1&region_id=1&tab=download#/downloadTab

yes your headphones are not a type that uses technology or drivers to identify itself to the computer therefore your headphones will be recognized as "speakers" that said you should be using Realtek drivers, and you can load the menu for it and split your signal output i.e. speakers on rear plug and headphones on front and be able to have both together as separate "front and rear speakers"

Note: if the word speaker confuses you, right click on your toolbar speaker icon, select playback devices, right click on the speaker connected to your headphones and in selecting properties you can rename it "Sony ZX310AP headphones"

 

thategghead

Prominent
Dec 29, 2017
4
0
510
0


Thank you very much for your help, but I have just tried my broken pair of headphones (can only hear from one ear and lots of static) and the headphones used to have drivers and was separate and as, but now the same problem occurs. I am not sure at all why this happened. I think my problem is the computer myself.

Edit: A message used to pop up saying how headphones were connected with my old headphones and others, but ever since I plugged the Sony headphones in, nothing popped up and the error started occurring for all headphones (unless its not the Sony headphones and im not aware)
 
Status
Not open for further replies.
Thread starter Similar threads Forum Replies Date
A Audio 2
LaMouette Audio 1
Alh9991 Audio 0
D Audio 5
S Audio 0
yugeshav Audio 1
A Audio 4
tulumba Audio 0
T Audio 3
V Audio 2
Pallier Audio 0
Techluv88 Audio 0
DiabolusGX Audio 0
M Audio 0
S Audio 0
B Audio 1
Hirina Audio 14
A Audio 2
T Audio 1
_Bata_ Audio 2

ASK THE COMMUNITY