Acer Aspire E1-572G laptop not shutting down completely after graphics driver update

Alpha666

Commendable
Jun 6, 2016
1
0
1,510
0
I have an Acer Aspire E1-572G laptop with the following specifications,

-Windows 8.1 Pro 64 bit,
-4th Gen i5-4200U 1.6 GHz
-4 GB RAM
-2 GB AMD Radeon R7 M265
-500 GB HDD

I've been using the device drivers which came in a CD along with the laptop. My AMD driver versions are as follows,

-Driver Packaging Version - 13.201-131002a-163934C-Acer
-Catalyst Version - 14.9
-AMD Catalyst Control Center Version - 2013.1002.1735.29729

I have tried updating the driver(completely removed old drivers and did a fresh install every time) multiple times. The driver installs normally with no errors. It works fine too.
But when I shut down the laptop, it won’t completely power down. The display turns off but the fan and power/indicator lights won’t turn off. I have to forcefully shut it down by holding the power button. And after I turn off my display for some time(Fn+F6) and try resuming, it won’t turn on. So forceful shut down; again.
I recently tried updating to the latest driver (version 16.15.2211) but still the problem persists. The only way to get out this situation is to install my old drivers(driver CD). After the downgrade the laptop shuts down normally.
Am I doing something wrong during the installation? Is there a way to update my drivers without having a negative effect? Or am I stuck with my ancient drivers forever? Any help would be much appreciated.
Thanks.

.
 
Hi,

Please do try a clean install of the graphics card driver.
- Go to Device Manager and uninstall the AMD graphics driver.
- Next is to open Programs and Features then uninstall anything related to AMD.
- Once completely uninstalled, download and install the latest driver,
- Reboot the laptop once completely uninstalled.
- After the reboot test it again and see if the same problem will persist or not.
 
Thread starter Similar threads Forum Replies Date
C Laptop Tech Support 1
M Laptop Tech Support 1
r090t9 Laptop Tech Support 5
Acer aspire e 15 Laptop Tech Support 2
Y Laptop Tech Support 0
HolyDog Laptop Tech Support 5
R Laptop Tech Support 4
Kirstie_P Laptop Tech Support 3
K Laptop Tech Support 1
S Laptop Tech Support 0
A Laptop Tech Support 1
D Laptop Tech Support 4
G Laptop Tech Support 2
E Laptop Tech Support 6
R Laptop Tech Support 1
P Laptop Tech Support 1
J Laptop Tech Support 3
S Laptop Tech Support 3
S Laptop Tech Support 1
K Laptop Tech Support 1

Similar threads


ASK THE COMMUNITY