Alienware M11xr2 won't start

careycat

Honorable
Nov 19, 2012
2
0
10,520
1
Hi,



Been searching theads on various forums. I have an Alienware M11r2 that won't power up. Here's what I know:



1) Plugging in the adapter lights the tip on the laptop-end of the adapter - so the adapter checks out.

2) Battery lights button is showing all lights on - so the battery checks out.

3) I replaced both the power switch (under the top bezel , took a total disassembly)

4) I replaced the CMOS battery (again total disassembly)



Is there anything I might have missed? There is absolutely no action happening when I press the power switch. I did post in an Alienware forum but so far no luck.

Been on this for 2 weeks. Any suggestions?
 

careycat

Honorable
Nov 19, 2012
2
0
10,520
1
I ended up replacing the motherboard, problem solved. Power switch and CMOS battery weren't the culprit, apparently it was the whole board. Thanks tho folks.
 

careycat

Honorable
Nov 19, 2012
2
0
10,520
1
I ended up replacing the motherboard, problem solved. Power switch and CMOS battery weren't the culprit, apparently it was the whole board. Thanks tho folks.
 
Thread starter Similar threads Forum Replies Date
S Laptop General Discussion 0
Tom156 Laptop General Discussion 0
O Laptop General Discussion 1
I Laptop General Discussion 1
mkbnk Laptop General Discussion 1
X Laptop General Discussion 1
SmokeyDevil Laptop General Discussion 0
R Laptop General Discussion 0
F Laptop General Discussion 0
Starwraith Laptop General Discussion 1
C Laptop General Discussion 0
S Laptop General Discussion 2
mjmani22 Laptop General Discussion 12
P Laptop General Discussion 1
S Laptop General Discussion 5
K Laptop General Discussion 1
C Laptop General Discussion 12
B Laptop General Discussion 3
B Laptop General Discussion 1
H Laptop General Discussion 7

ASK THE COMMUNITY