Audacity recording quality drops when using Action!

Minerelf

Estimable
Aug 1, 2015
6
0
4,510
0
Hey, I'm having a weird issue in which the quality of my audio recordings in Audacity drop drastically when I activate my screencapture. The quality is pretty good to start out, then when I hit record on my screen capture the audio gets much louder and starts to echo. I have the most recent version of both Audacity and Action! I'm running Windows 10 on an Intel I5 6600K with 8GB of RAM. If anyone knows of a fix for this and could let me know that would be awesome!
 

Diay

Distinguished
Dec 29, 2011
0
0
18,510
1
  • Deleted by N/A
I was having the same exact issue when I stumbled upon your post, so I decided to come back and post what fixed it form me.

First of all go tou your recording devices, right click your mic, go to the levels tab and take note of the number you have there.

Next go to Action! -> Settings -> Microphone Settings. In here if the volume option is something that is not the same number we took note on the previous step, that is the problem. These numbers should be the same so Action! doesn't alter them you you press record.
 
Try assigning Audacity realtime priority.

Open task manager.
Find Audacity on the Details tab.
Right-click it -> Set priority -> realtime

Windows was originally designed as a single-user desktop OS, not a multi-user OS, so it defaults to apportioning CPU time in large chunks. This can cause problems with tasks which require fast CPU response like recording audio. Giving it realtime priority should help. It's not as good as a real time OS, or an OS designed from the beginning to be multi-user like Unix (which is why the Macs tend to do audio recording better - OS X is based on BSD Unix). It may end up starving the screen capture process though.

If that doesn't work, you can try assigning Audacity and your screen capture program to different cores. Same procedure as above, but instead of Set priority, choose Set affinity. All processes are originally allowed to run on all cores. Simply make sure the two programs can only run on different cores. (This may not work. This sort of problem with competing realtime tasks is why dedicated video capture and audio capture hardware exist. The hardware does the busywork of buffering and capturing, and the CPU only has to deal with writing the resulting data to disk.)
 

Minerelf

Estimable
Aug 1, 2015
6
0
4,510
0
Hey, sorry about the delayed response. I'm not at my desktop right now but I wanted to let you know I saw your message and I'll let you know if it works when I have a chance to test it.
 

Minerelf

Estimable
Aug 1, 2015
6
0
4,510
0


Alright, I tried both of these suggestions and neither of them fixed the issue. Do you have any other ideas? I checked memory and CPU usage while recording, neither came close to maxing out.

 
Ok, re-reading your original report and looking up what Action! actually does, do you have a microphone attached to your computer or does the computer have a built-in mic? It sounds like when you turn on Action! screen recording, it's also turning on the microphone so you can add voice commentary. This microphone is picking up the sound from your speakers, causing the echo and louder sound.

If you're not adding voice commentary, see if there's an option in Action! to turn off the microphone.

If you are adding voice commentary, you can try turning down the speaker volume, you can try moving the speakers further away from the mic (or mic further away from the speakers), or you can switch to a higher-quality microphone which sits closer to your mouth and/or has background noise cancellation (most headset mics have this).
 

Minerelf

Estimable
Aug 1, 2015
6
0
4,510
0


I am using Action! to record commentary, I'm using an external microphone connected to my computer to do my audio. My computer outputs sound through headphones so it shouldn't be picking up anything from them should it?
 
Thread starter Similar threads Forum Replies Date
L Audio 0
M Audio 3
jessitokki Audio 1
rclr Audio 2
kobinath Audio 1
Jmatsumoto Audio 1
tquinnddddddd Audio 1
M Audio 1
Z Audio 1
I Audio 1
R Audio 2
M Audio 6
M Audio 1
S Audio 1
CreepyBobo346 Audio 2
W Audio 4
A Audio 1
G Audio 1
J Audio 5
G Audio 38

ASK THE COMMUNITY