Blu-ray player won't display image on TV

Aug 3, 2018
1
0
10
0
Hello!

I have a Samsung KS8000F 55 inch TV, a Samsung UBD-M7500 blu-ray player and a Denon AVR- S710W audio receiver.

Strange thing happens with the blu-ray player. When I turn on the blu-ray player first, it will turn on the audio receiver and TV, put it on the right input, but no image will display on the TV. If I turn the blu-ray off and on again, the image will display.

If I turn on the TV and audio receiver first, then turn on the blu-ray player, the image will display just fine. Now, this wouldn't be that big of a deal, but I just got a universal remote. When I use the universal remote to turn everything on, the image will not display, despite it being set to the correct input.

Anyone have an idea what's going on here? Thanks!
 
Have you checked what happens when you connect the player directly to the TV?

If this bothers you a lot - connect player to TV for video, and player to Denon for audio, and reprogram your remote to switch correct inputs here and there.
 
Have you checked what happens when you connect the player directly to the TV?

If this bothers you a lot - connect player to TV for video, and player to Denon for audio, and reprogram your remote to switch correct inputs here and there.
 
Thread starter Similar threads Forum Replies Date
B Streaming Video & TVs 0
4 Streaming Video & TVs 8
S Streaming Video & TVs 2
S Streaming Video & TVs 1
V Streaming Video & TVs 1
P Streaming Video & TVs 2
J Streaming Video & TVs 1
Y Streaming Video & TVs 10
G Streaming Video & TVs 8
E Streaming Video & TVs 1
Y Streaming Video & TVs 10
C Streaming Video & TVs 2
E Streaming Video & TVs 4
G Streaming Video & TVs 1
C Streaming Video & TVs 1
A Streaming Video & TVs 2
G Streaming Video & TVs 1
G Streaming Video & TVs 5
G Streaming Video & TVs 4
kinney Streaming Video & TVs 3

ASK THE COMMUNITY