Can't install latest version of Remote Go!

JoshiMan4

Estimable
Oct 13, 2014
3
0
4,510
0
I've downloaded Remote GO! 3.00.10 from the ASUS driver website, but whenever I open up the setup.exe or the asus_setup.exe, nothing happens. I can see that the process is running though the task manager, but nothing actually opens up. I've ran the programs as an administrator, but nothing happens. I'm doing this because the app requires this new version. I've also tried using EZ Update through AI Suite III, but it says "there is no need to update the environment". My motherboard is a Gryphon Z87 and I have an i5-4670k. Please help!
 
Might have just been a bad download. Had that happen to me a few times a couple weeks back, installing the ASUS software on a new build. Download it again once or twice to see if it is as simple as that, before trying any other fixes.
 

JoshiMan4

Estimable
Oct 13, 2014
3
0
4,510
0


I'll see if that works. Hopefully it does!
 

JoshiMan4

Estimable
Oct 13, 2014
3
0
4,510
0


Still doesn't work. Any other ideas?
 
Thread starter Similar threads Forum Replies Date
B Apps General Discussion 1
D Apps General Discussion 6
M Apps General Discussion 1
F Apps General Discussion 4
C Apps General Discussion 1
E Apps General Discussion 2
S Apps General Discussion 1
S Apps General Discussion 2
A Apps General Discussion 3
K Apps General Discussion 4
M Apps General Discussion 4
meloonharrier1199 Apps General Discussion 24
R Apps General Discussion 1
G Apps General Discussion 2
H Apps General Discussion 1
P Apps General Discussion 1
M Apps General Discussion 1
T Apps General Discussion 7
viveknayyar007 Apps General Discussion 0
I Apps General Discussion 1

ASK THE COMMUNITY