Card reader not working

Roniish

Distinguished
Jan 24, 2008
2
0
18,510
0
Hi guys, I recently encountered a problem with my F: disc which is used to open up the CF card.

I tried inserting my CF card into the card reader slot, but I get no response. the green light on the Card reader comes on for about one or two seconds, but then it turns off again and nothing happened. nothing showed up as a movable disc on the screen. it was just dead.

http://www.tomshardware.co.uk/forum/29159-31-card-reader-problem

That's the only topic I could find about a CF card problem, but it did not solve mine. mine doesn't even show up as a movable disc, it's just dead.

Any help is greatly appreciated!

//Ron
 

AzStar

Distinguished
May 6, 2008
5
0
18,510
0
Hi:

There are a few possibilities

■ The card reader is DEAD but with the light
coming on it is probably not
■ The card has a contact problem, with CF
cards you sometimes can get something
plugging the holes in the card itself, check with
a needle. (You will probably have a problem
if you stick it back in the camera too)
■ There is a USB connection problem, take a
look at the contacts on your reader and on the
computer.
■ The card has a format problem. If it works in
your camera still this is not the problem.

You probably should try plugging your Reader/Memory Card
into another computer with XP. Most card readers
come up right away without any additional installation
needed.

If none of these work you may need a new CF Card reader,
you can get one from SterlingTEK for about $10

www.sterlingtek.com/simphot.html?_Compact_Flash_Memory_Card_Reader

Chris
 

piratepast40

Distinguished
Nov 8, 2006
37
0
18,580
0
I've had one of mine do that also. Mine was a loose USB header connection on the mobo. Just unplugged it and plugged it back in and it worked fine.
 

webfairy

Distinguished
Jan 27, 2009
1
0
18,510
0
I have a lenovo X61 laptop. The SD slot is not working.
Earlier the DVD burner was not working either.
It turns out that a failed Itunes installation had mis-set the upper and lower registers in the registry, and the fix was a bit of registry editing to get rid of the false values.
I have a hunch there's a similar problem with the SD slot, since both failed at the same time.
 
Thread starter Similar threads Forum Replies Date
O Digital Cameras 1
A Digital Cameras 3
Z Digital Cameras 2
T Digital Cameras 1
J Digital Cameras 13
T Digital Cameras 2
M Digital Cameras 1
M Digital Cameras 4
songorocosongo Digital Cameras 7
K Digital Cameras 1
M Digital Cameras 1
T Digital Cameras 1
3 Digital Cameras 1
E Digital Cameras 3
D Digital Cameras 1
G Digital Cameras 3
G Digital Cameras 2
G Digital Cameras 22
M Digital Cameras 3
G Digital Cameras 2

ASK THE COMMUNITY