Charging problem ASUS X550D A10

Saint_Avenue

Estimable
Feb 6, 2016
1
0
4,510
0
I have Asus X550D , the problem is sometimes my laptop charging only at 75% then stop. The LED light also went off with "Plugged in , not charging". Then after for a while, it start charging again and went off at 90%. Then charging again until full.

And another problem is when plugged the charger at 80% above, it will says "Plugged in , not charging" but start charging only at 70%.

(My battery still new since I replaced it )
 
Hi,

Please do try these troubleshooting steps that may help in identifying the issue.
- Remove the battery of your laptop then boot it up with just its AC adapter and see if it will stay on.
- Next is to test your AC adapter and see if it's supplying enough voltage or better yet try a different AC adapter that has the same voltage with yours.
- If these doesn't work do uninstall/reinstall "Microsoft acpi-compliant control method battery" from Device Manager.
- Last resort if all these will not work is to do a factory reset with your laptop.
 
Thread starter Similar threads Forum Replies Date
A Laptop Tech Support 1
S Laptop Tech Support 0
D Laptop Tech Support 1
ara3h sarang Laptop Tech Support 0
RegisZDB Laptop Tech Support 1
L Laptop Tech Support 0
D Laptop Tech Support 8
AG95 Laptop Tech Support 5
N Laptop Tech Support 1
babu566 Laptop Tech Support 5
A Laptop Tech Support 1
A Laptop Tech Support 2
R Laptop Tech Support 2
T Laptop Tech Support 1
P Laptop Tech Support 2
S Laptop Tech Support 1
W Laptop Tech Support 1
D Laptop Tech Support 1
D Laptop Tech Support 1
V Laptop Tech Support 5

ASK THE COMMUNITY