Chrome pages not loading

John_Aten

Estimable
Sep 23, 2015
2
0
4,510
0
Hi all,

For the last week or so whenever I click a link to open in a new tab, several tabs open with the same link. Also, sometimes pages would not load font colours and styles, or graphics. Flash pages were also not working regularly.

I've updated Chrome, disabled hardware acceleration, disabled Kaspersky Internet Security, and reset Chrome.
I'm out of ideas.

I updated Flash to the latest version, 19,0,0,185 about a week ago. Interestingly, I get a glimpse of flash working, then it often stops. I disabled flash in diagnosing, but otherwise it made no difference. Apparently, Flash is extremely buggy this year. I wonder if Chrome is having side issues with it?

This is a popular topic, Chrome pages not loading, but nobody has any answers.
I remember the same problem a couple years ago, and it was an issue with anti-virus programs, but I can't remember what it was.

Anybody?

Windows 10
Chrome 45.0.2454.99
KIS 16.0.0.614(a)
Flash 19,0,0,185

Thanks ANYONE!
 

John_Aten

Estimable
Sep 23, 2015
2
0
4,510
0
Okay, finally, after 6 hours, fixed it.
I had to reinstall Chrome, downloading by IE. It took an hour to figure out why it wasn't actually downloading, after I'd shut off the usual culprits, AND downloaded Chrome's OFF-LINE INSTALLER.

Problems fixed. For now, I'm sure.
 
Thread starter Similar threads Forum Replies Date
R Apps General Discussion 0
C Apps General Discussion 1
BlueMoon1890 Apps General Discussion 0
H Apps General Discussion 2
I Apps General Discussion 2
D Apps General Discussion 1
T Apps General Discussion 1
P Apps General Discussion 1
S Apps General Discussion 4
J Apps General Discussion 4
J Apps General Discussion 1
A Apps General Discussion 4
F Apps General Discussion 5
L Apps General Discussion 1
Jacob McIntosh Apps General Discussion 2
C Apps General Discussion 1
W Apps General Discussion 1
T Apps General Discussion 2
D Apps General Discussion 3
A Apps General Discussion 2

ASK THE COMMUNITY