Computer not sending Any Output to any HDMI/USB/DVI Port

Icemansun

Estimable
Jan 2, 2015
2
0
4,510
0
First of all, I'd like to say that I have no idea if this is the write section to be writing this in. So I'm sorry if I put this thread in the wrong section.


Anyways, now onto the problem. I was playing a video game, when all of a sudden, my computer just randomly shut down. There was no warning, the computer just shut down. I thought that this was a bit weird, but I just hit the power button on my computer. The computer turned on and the lights inside the computer turned on, but it didn't send any output to my monitor, keyboard, or mouse.


Here is a video of what happens now when I try to turn the computer on: http://youtu.be/yU9jKaLHB7I


My PC Specs: https://pcpartpicker.com/user/Icemansun/saved/#savedbuild_1857435

Please help me!
 

Icemansun

Estimable
Jan 2, 2015
2
0
4,510
0


Yeah, I tested the PSU, it's dead :(

Guess it's time to get a new PSU.
 
Thread starter Similar threads Forum Replies Date
TacoFun Laptop Tech Support 0
TypicalOven Laptop Tech Support 0
R Laptop Tech Support 1
cwf Laptop Tech Support 1
Naroa Laptop Tech Support 0
C Laptop Tech Support 5
Dragonsbloodmoon Laptop Tech Support 2
-Maxusestech- Laptop Tech Support 10
M Laptop Tech Support 0
M Laptop Tech Support 4
W0lfs0ng Laptop Tech Support 0
Tanyalin Laptop Tech Support 1
yumri54 Laptop Tech Support 3
Xman298 Laptop Tech Support 1
K Laptop Tech Support 7
S Laptop Tech Support 2
A Laptop Tech Support 4
R Laptop Tech Support 1
P Laptop Tech Support 2
M Laptop Tech Support 3

ASK THE COMMUNITY