CyberLink Power DVD 18 Ultra Blu Ray Playback issues

eperez524

Prominent
Jun 5, 2017
2
0
510
0
Whenever I'm watching a blu ray movie using cyberlink powerdvd 18 ultra, sometimes playback will stop in the middle of the movie with this error message "CyberLink PowerDVD could not read a file on this disc, playback will stop" and the movie just stops playing. Sometimes it won't even load the blu ray disc or it would only read and play some movies. This tells me its able to at least read and play blu rays, but with some issues. It plays dvds just fine. I'm using an external Samsung blu ray writer manufactured in 2014 connected via usb port. I've installed the latest display drivers for my gpu and all the windows updates. I've tried upgrading the firmware for my blu ray writer but couldn't find a driver for windows 10 and device manager says that the latest driver is already installed. All of my blu rays are retail disks and the same thing happens even if I play an old blu ray. I have the PC connected via HDMI port. Any help would be appreciated.

System specs

HP Desktop

CPU - 2nd Generation AMD Trinity A8 - 5500 APU 3.2 GHZ Quad Core Processor (Turbo boost to 3.7 GHZ)

GPU - MSI Radeon R9 390 8 GB GDDR5

HDD - Western Digital 1.0 TB

Operating System - Windows 10 Pro

Monitor - HP 2511x 1080p

Ram - 10 GB DDR3

Blu-ray Drive - Samsung SE-506 CB BD RE

PSU - Thermaltake 750 watt 80 Bronze Plus
 

eperez524

Prominent
Jun 5, 2017
2
0
510
0
I tried swapping the USB cable for other ones but the problem got worse. The PC would get signal and recognize the drive with the other cables that I tried but whenever I put in a Blu-ray disc, the signal would totally get lost and wouldn't come back. This happened with at least two other cables that I tried (They were bought brand new to charge my PS3 controllers and the Blu-ray drive uses the same mini b connector on the other end as the PS3 controllers).This didn't happen with the original cable I was using. So after trying different cables I decided to reconnect the original cable I was using and today I fired up CyberLink PowerDVD 18 and tried to play a Blu-ray that didn't used to load at all and all of a sudden it played, loaded, and ran flawlessly. I don't know how or why it finally ended up working. I also have a Dell desktop and ASUS laptop and I never had any problems with Blu-ray playback on those computers using this same cable and Blu-ray drive and connecting via a USB 2.0 or USB 3.0 port without using a hub. I don't know why the other cables didn't work if they charge my PS3 controllers just fine. Maybe they're just dedicated for charging/power and not for data transfer which I think the original cable that I had provided all these features. I did find another USB cable that I had in my drawer and that worked flawlessly as well. I'll try playing and watching different Blu-ray movies using these two cables that I found working and hopefully all works well.
 
Thread starter Similar threads Forum Replies Date
L Apps General Discussion 0
G Apps General Discussion 2
B Apps General Discussion 7
R Apps General Discussion 1
A Apps General Discussion 1
G Apps General Discussion 0
H Apps General Discussion 1
U Apps General Discussion 1
TDice Apps General Discussion 6
Wolfshadw Apps General Discussion 2
B Apps General Discussion 2
Brian Ting Apps General Discussion 1
D Apps General Discussion 3
gamingguru76 Apps General Discussion 3
F Apps General Discussion 2
I Apps General Discussion 3
N Apps General Discussion 7
tribulator135 Apps General Discussion 4
H Apps General Discussion 3
brendin Apps General Discussion 2

ASK THE COMMUNITY