Question Dell XPS 9550 freezes after removing ac power and on battery power

Feb 8, 2020
6
0
10
0
I have a 3 year old Dell XPS 9550 which had a new battery 18 months ago.

The problem I have is that when I unplug the AC power cord the laptop begins to freeze. The mouse can be moved with trackpad. Window can be selected a little bit but can't switch between apps. Then within 30 seconds of pulling the ac, the laptop freezes completely and a few seconds later BSOD - critical process failed. The BSOD remains on zero % untill the battery runs out (haven't checked how long it goes on battery for but at least over an hour.)

If I leave the laptop on ac, if the system goes to sleep, it won't wake. (not sure if it is going to sleep or not but the screen is blank) and I have to power off to restart.

If I try to boot on battery, the Dell logo appears with spinning dots on it and sticks spinning.

I have tried other suggestions like disabling C-State with no luck.

I have tried to restore the laptop using windows recover on usb, dell recovery on usb and recovery partition several times. If I get in to one of the recovery screens "Select reset option" screen, the "Reset to factory settings" radio button is disabled and have to select "Reset and update"

I replaced my 500TB SSD with an AData 1TB SSD about 5 months ago, cloned and the 1TB SSD has about 4-5 partitions.

I downloaded Ubuntu on to a thumb drive and can boot with that on battery or ac and the system survives unplugging an plugging in of ac.

I have tried different power options that I have seen people suggest online but no luck.

Can this be a hardware issue that only presents itsself when booting from SSD but not from USB?

Has anyone used tech support to pay to get this kind of issue fixed? Any idea how much dell charges in australia for this?

Dell does do our hardware at work, so might try seeing if I can get someone to look at it, but don't think it will be possible.

Rasied a query will Dell support website but they just say out of warranty and ask the community.

Anyone had any luck getting Dell to fix a 3 year old laptop in Australia. Might be slither of hope with ACCC?

Any other settings or procedures that I can try?

During an before system restores that I have performed, the bios and drivers according to Dell update is up to date and nothing needs updating.

Any tools that can be used to diagnose?

Would local PC repair shops have the skill/time/economic to resolve?

Perhaps there are some drivers that need to be updated that Dell has not recognised.

Perhaps there are some drivers that need downgraded?
 
If you upgraded any drivers outside what the manufacturer's site says are for your device, then I would downgrade to those. Just because there are new drivers doesn't mean they are for a particular system.

Now, have you tried, while Windows is installed, starting up in "Safe Mode" to see if it loads fine in there? While it doesn't seem like hardware (per your saying it runs fine on another OS) going into "Safe Mode" is another good way to check.

If nothing happens while you are in there, then it is likely something on the system. Bad program, virus, malware, etc. So if it works OK there, then you need to clean your system.

How to enter "Safe Mode" when booting the computer.

In Windows 8 and 10...

As your computer restarts, press F8 (possibly a few times) to enter "Safe Mode"

a. Press the "F4" key to Enable "Safe Mode".
(The computer will then start in "Safe Mode" with a minimal set of drivers and services.)

b. Press the "F5" key to Enable "Safe Mode" with Networking.
( Once "Safe Mode" with Networking starts, Windows is in Safe Mode, with additional network and services for accessing the Internet and other computers on your network.)

c. Press the "F6" key to Enable "Safe Mode" with Command Prompt.
(In "Safe Mode" with "Command Prompt" starts Windows in Safe Mode, with a Command Prompt window instead of the Windows interface. This option is mostly only used by IT professionals.)

Now sign in to the computer with your account name and password. (If you have one set.) When you are finished troubleshooting, you can exit "Safe Mode" restarting your computer.


In Windows 7/Vista/XP...

1. Immediately after turning on the computer, or restarting it (usually after you hear your computer beep), tap the F8 key, repeatedly, in 1 second intervals.

2. The computer will then display hardware information and run a memory test.

3. Next the "Advanced Boot Options" menu will appear.

4. In the "Advanced Boot Options" menu use the arrow keys to select "Safe Mode" or "Safe Mode with Networking" and press ENTER.
 
Feb 8, 2020
6
0
10
0
thanks for your response
If you upgraded any drivers outside what the manufacturer's site says are for your device
I have only used the Dell update site for selecting drivers. That site says I am up to date with their recommended drivers
Now, have you tried, while Windows is installed, starting up in "Safe Mode" to see if it loads fine in there?
Have tried safe mode and still freezes when switching from ac to battery
So if it works OK there, then you need to clean your system.
I have tried reinstalling windows server times using different options from Dell restore and windows restore sites but no luck yet for the approaches I have tried
 
If it is still freezing even when in "Safe Mode" then it is likely a hardware issue. and not a software one.

It could be the battery, the charger, the port, or even something else. I would suggest calling around to local places for an estimate on diagnosing which it is. They should be able to do that for a reasonable price. Then you can know for certain which part is in need of replacing.

Unless, of course, you feel comfortable doing the work yourself.
 
I would think it wouldn't be hardware if not doing with another OS, however you say it still does it in "Safe Mode", which accesses a lot less than normal Windows.

You said you ran the other OS from a USB drive? If not installed on the main hard drive then that could be the issue. It could even be a faulty drive.

At this point, it is trial.
 
Feb 8, 2020
6
0
10
0
I would think it wouldn't be hardware
Ok, some more observations.

I dug out the original 500GB SSD (which I was using for something else so was reformatted).
I cloned the 1TB SSD that is currently inside the laptop to the 500GB drive, which is in an enclosure.

I restarted the laptop via F12 boot options,
From the two boot options, one was Windows something or other.
The other was the ADATA 1TD drive.

I am not sure why but on one or more attempts, the drives showing in explorer are
c: 500GB
d: 1TB.
Now I don't know which drive the first option boots against, but I am speculating that it is from the external 500GB drive.

Can pull out ac and it hasn't froze yet (typing this via the DELL XPS)

I guess the next thing to try is to swap the SSD sticks and see if it will boot off the 500 GB SSD and see what happens. Will keep you posted
 
Feb 8, 2020
6
0
10
0
So tried reinstating the original 500GB SSD back in the laptop and worked fine on both battery and AC power.

Also tried booting from the External Enclosure with 1TB SSD, interestingly when I did that only the 1TB SSD showed up in explorer. Perhaps an effect of one drive being a clone of the other and that worked ok too.

So what is the problem with the DELL XPS when the ADATA XPG SX8200 PRO 1TB is installed inside the laptop?
Technically, the drive doesn't appear to be faulty when used as an external drive, but is somehow incompatible when used inside the laptop.

Is it drawing too much power?
Is it a driver issue? Windows 10 appears to use a Microsoft driver for NVMe drives.

Will another brand of 1TB SSD work? I'm guessing so.

I have raised a ticket with ADATA.
 
Last edited:
Feb 8, 2020
6
0
10
0
ADATA got back to me and suggested the drive may be faulty.

I have however managed to fix the issue finally, this is what I wrote back to ADATA support with and hopefully might help someone else out who is having issues with their ADATA SSD or ADATA SSD Toolbox:

Hi, I think after months of trying, I have finally found out what the issue was and you should note this for future customers having issues.
The thing that made me try something different was trying to use the SSD toolbox to wipe the drive before returning it.
It has never worked for me, only tried it twice, once when I got the drive and once trying to wipe the drive.
The SSD Toolbox error said "No available SATA disk! Try using a windows AHCI driver for SATA controllers. This window will quit"
This led me to search and find a page talking about "Switch Windows 10 from RAID/IDE to AHCI".
I think that my Dell XPS 9550 may have an Intel Drive in it, that a particular setup to allow high speed access or something, not sure, its all educated guesses at acronyms to me.
Needless to say I can now access SSD Toolbox and my bios is now in AHCI mode rather than RAID.
It looks like I can now use the laptop with the ADATA SSD both in AC and Battery and can switch between the two without issue.
I hope the above helps someone else

Summary: "If you have a Dell XPS 9550 (or perhaps other laptop with an Intel NVMe SSD) and it is set to RAID or IDE and you want to replace it with an ADATA SSD, you will need to switch the drives mode in to AHCI in bios. - https://support.thinkcritical.com/kb/articles/switch-windows-10-from-raid-ide-to-ahci

I put the original 500GB SSD in the laptop and switched to AHCI and the laptop would not boot (I think), putting it in to safe mode, then out of safe mode fixed it.
I then put the ADATA SSD in and it didn't boot, then put laptop in safe mode, reboot, take out of safe mode, reboot and all was working well after that. I guess although the bios was in AHCI, the windows installation still had to switch drivers to that and going in to safe mode and then back out, allowed the AHCI drivers to be installed or something along those lines.
 
Last edited:
Thread starter Similar threads Forum Replies Date
R Laptop Tech Support 1
Alicat111111 Laptop Tech Support 1
russellhunt04 Laptop Tech Support 1
stmoritz Laptop Tech Support 13
C Laptop Tech Support 9
D Laptop Tech Support 11
abacus143 Laptop Tech Support 1
D Laptop Tech Support 5
G Laptop Tech Support 1
R Laptop Tech Support 0
rahulkumarbudhwani Laptop Tech Support 1
sm23 Laptop Tech Support 9
D Laptop Tech Support 6
shresthabijay26 Laptop Tech Support 1
N Laptop Tech Support 1
R Laptop Tech Support 1
drahstul Laptop Tech Support 1
F Laptop Tech Support 10
D Laptop Tech Support 0
I Laptop Tech Support 3

ASK THE COMMUNITY