Dell XPS15 L502X overheating and fan problems

kerio_orisa

Commendable
Jun 13, 2016
17
0
1,560
0
Hi,
My laptop was heating up a bit too much (temperature above 90’s in normal load, and sometimes shutting down after hitting 100C), so I finally decided to open up my Dell XPS 15 (L502X) and replace the thermal paste. I have few questions:
When I opened it up, apart from the thermal paste on the cpu (i7-2630QM) and gpu (Nvidia GT-540 2gb), there were several white pads, and one grey pad. The grey pad was above the motherboard HM67 chip. This is the first time I ever saw a heat sink with thermal pad needed to cool down the motherboard. Or am I missing something? And what are all these small white pads? They seem to be covering different chips on the motherboard. Does anyone know the width of these white pads, and grey pads? Are all of these thermal pads to conduct heat? Or some are meant to block heat? I think the white ones are meant to block health, but I may be wrong.
Anyhow, after replacing the thermal paste (didn’t do anything with the pads, since I wasn’t expecting to see them anyway), the temperature of CPU and motherboard remains in 70’s C, and GPU in 60’s C under normal load (20 browser tabs, and some MS Office work alongside). But the fan works in an annoying manner with bursts of sounds, instead of constant sound. It is rather annoying, and I rather have the fan working the whole time than this annoying bursts. Any solution to fix this?
I am also considering downgrading to I5-2540M (lower TDP, and dual core), but its not worth it if the fan is going to behave in similar manner.
 

kerio_orisa

Commendable
Jun 13, 2016
17
0
1,560
0
I have narrowed down the annoying fan noise problem. It is something to do with hard disk. My XP215 (L502X) came with a 750 GB WD 7200rpm hard disk. I created an image of my system on a portable drive, and restored the image on a 500 GB Hitachi 7200rpm, and well, the fan noises were gone. I don’t know how and why, but the fan behaves much better. To make sure that it is something to do with hard disk, I used the same system image to restore Windows on another 500GB hard disk (5400rpm), and the fan noises were back on that one. So, the only hard disk (among the three that I have) without fan noises is the Hitachi 500gb 7200rpm. I can’t explain why is it so. It is not a Windows issue, since I used the same system image, and did not re-installed a fresh Windows 7. Maybe some sort of software incompatibility with some hard disks, or something else.

Another strange thing is that I thought the laptop would remain cooler on a slower 5200rpm hard disk, as the cpu would have to waite for processing due to slower read I/O from a slower hard disk,, but it apprently gets much warmer on a 5200rpm hard disk (compared to both 7200rpm hard disks).
 

__SID__

Commendable
Jun 1, 2016
10
0
1,590
5
the thermal pads are quite thin, thinner than normal thermal pads you can buy off ebay, especially the smallest thermal pad on the L502x. I replaced mine, but I had to slice them thinner otherwise the GPU does not make contact with the paste. What thermal paste did you use? Arctic Silver 5 is fine, or MX-3 is great too.
 
Thread starter Similar threads Forum Replies Date
A Laptop General Discussion 9
P Laptop General Discussion 1
B Laptop General Discussion 1
S Laptop General Discussion 4
S Laptop General Discussion 2
D Laptop General Discussion 2
A Laptop General Discussion 11
G Laptop General Discussion 4
M Laptop General Discussion 1
K Laptop General Discussion 2
trama09 Laptop General Discussion 4
T Laptop General Discussion 2
M Laptop General Discussion 1
Y Laptop General Discussion 2
Y Laptop General Discussion 4
S Laptop General Discussion 2
H Laptop General Discussion 7
L Laptop General Discussion 1
N Laptop General Discussion 3
S Laptop General Discussion 20

ASK THE COMMUNITY