(FIXED) Airpods - strange issue while using PC


Oct 12, 2014
I bought a USB 4.0 dongle for my PC, and plugged into Win-10-64 bit, using in a Core i7 4770, H97M-D3H motherboard. I also have the Airpods from Apple, bluetooth headphones. I paired them and tried listening to everything from my PC, and they worked OK.

One thing I noticed is that once paired, if BT is reenabled (in case you disable), the Airpods will reconnect automatically, meaning that if you are listening to your iPAD they will "steal" the signal.

I created a shortcut in the desktop to make things easier, and

Now, about the issue I am having here:

- First of all: using Media Player Classic Home Cinema or VLC, it doesn't matter.

- If a video has multiple subtitles or audio tracks, and I switch to another while using these Airpods, the audio is 100% muted and switching back to the previous track won't fix this. I have to close MPC/VLC and reopen, then the audio comes back.

Meaning that if I want to listen to #track 2, I have to disable BT and reenable, if (and only if) the audio from track #2 is playing already.

Now what kind of bug is that? It seems that the mere switch of a track (also subtitles) can trigger this.

There's also the fact that the emulator SNES9x is muted for these Airpods, while epSXe and PCSX2 (for example) are not, but this is another issue that is perhaps not related to this, and that I already reported in their online board.

Now, what could be causing this other issue?


Oct 12, 2014
I discovered what was causing this issue, with the dongle CSR8510 A10: it was the fact that I was using Windows native drivers. When I switched to these drivers mentioned here:


The problem was solved.

I tried a newer version from here:

But it didnt't recognize anything properly, including the Airpods.

But I will not be able to stay with any of them. That is because the DS4 controller (last version) could not be detected. I see that these drivers are from 2011-12 and that explains why they can't detect devices to be paired most of the time. I use Windows 10, and since I used Windows native drivers, that explains why the mere switch of audio/subtitle tracks was enough to mute everything. Unfortunatelly there are no recent drivers, so I will have to find another USB dongle instead of this cheap one.

P.S. I did more tests:

And discovered that if we switch to "Airpods Hand-Free - Handset" the audio quality will be very poor, but this problem will not happen. The other option is Airpods - Headphones - Stereo". Maybe this has something to do with a conflict? I tried disabling the former, but that didn't do any good.


And here's a workaround while using MPC-HC with a file that contains multiple tracks: create a shortcut and place in Windows desktop. Write that inside it:

%windir%\System32\rundll32.exe shell32.dll,Control_RunDLL mmsys.cpl,,1

Then, open and close that shortcut while switching to another audio/subtitle track. The audio will be heard.


Oct 12, 2014
And a very important update:

The problem described here is gone! Finally!

It seems that last Windows 10-64 updates have fixed this issue (Creator's one). I no longer need to do the procedure described in that link, and switching between audio/subtitle tracks while using MPC-HC and other players does not mute the audio anymore while using the Airpods!

So, after all this time it was all a bug in Windows? Not the dongle's fault... I was even planning to buy a new one.
Thread starter Similar threads Forum Replies Date
vinhero Audio 0
B Audio 3
DownplayZ0 Audio 1
D Audio 1
Help of the me :D Audio 2
Z Audio 0
K Audio 0
N Audio 0
G Audio 1
kryonas Audio 2
kaosity Audio 1
frostii123 Audio 1
SupremeEditor Audio 0
WolfSRB19 Audio 5
Gatorceri Audio 1
B Audio 0
L Audio 0
M Audio 0
D Audio 2
C Audio 0