Fn key will not work on Acer Aspire 5742z! with internal or external keyboard

otherdreams

Distinguished
Jun 15, 2009
6
0
18,510
0
I have an Acer 5742z laptop with a perfectly functional keyboard, except that the Fn function key has stopped working.

These are the steps I have tried:

--Replaced the keyboard with a known good spare from my old 5742z.

--Tried an external USB keyboard.

--Tried the Windows On-Screen Keyboard and online keyboard testers. None register the Fn key with internal or external keyboards.

--Checked BIOS for a "Fn Enable/Disable" option. Did not find this option...?

--Updated my BIOS from V1.16 to V1.30.

--Uninstalled and reinstalled the Dritek/Acer Launch Manager utility.

--Checked Task Manager to see that Launch Manager is running.
(Processes LMmanager, LMworker, MMDx64Fx, Dritek WMI Service are all running from the Program Files (x86)/Launch Manager/ directory.)

--Tried switching all of these processes to Run As Administrator and to Vista Compatibility.

--Loaded ALL startup programs in msconfig. (Dritek Launch Manager was listed there.)

--Switched the Keyboard Device Driver to an incorrect PS/2 driver and then back to the Standard PS/2.
(Is there a better driver for this keyboard??
https://ae01.alicdn.com/kf/HTB16roubRfM8KJjSZFhq6ARyFXaf/OEM-US-Layout-Keyboard-Replacement-for-Acer-Aspire-5742-5742G-5742Z-5742ZG-5745-5745G-5745P-5745PG.jpg )


...all without success!


What is left?
I don't think it's hardware, so somehow the key is disabled in firmware or OS?
Maybe I need new keyboard drivers?
Or...?

This has been driving me crazy for months. Please advise.
Thank you!
 

Lutfij

Splendid
Moderator
Speaking of OS, what are you working with? Since when did the issue crop up? You could try and use keyboard tester to verify if the keyboard itself isn't registering a keypress. You might also want to inspect the ribbon cable with which it connects to your laptop motherboard.
 

otherdreams

Distinguished
Jun 15, 2009
6
0
18,510
0

Thanks for the reply Lutfij!
I'm using Windows 7 Home Premium 64-bit.


I do not believe it is the ribbon cable because I have tried two different internal keyboards plus one USB external keyboard. None of them have a Fn key that registers with online keyboard testers or OSK.


The issue started several months ago. First I lost some Fn functions and then all of them.

Perhaps something like ComboFix scan could have inadvertently knocked out a critical component. Also I periodically disable windows startup programs and services..

Launch Manager uses msiWMI service, but when I look at that services properties it says it has no dependencies and depends on no other services or processes. .
Could the Launch Manager processes have lost their connection to Launch Manager services ?
 
Thread starter Similar threads Forum Replies Date
H Laptop Tech Support 0
Y Laptop Tech Support 10
M Laptop Tech Support 0
G Laptop Tech Support 1
granadt Laptop Tech Support 2
G Laptop Tech Support 6
A Laptop Tech Support 1
Codydebruh Laptop Tech Support 3
EsmaGraham Laptop Tech Support 17
jimi.friess Laptop Tech Support 1
R Laptop Tech Support 1
C Laptop Tech Support 1
Expmt Laptop Tech Support 4
dantheman95lbp Laptop Tech Support 3
O Laptop Tech Support 3
agten Laptop Tech Support 14
M Laptop Tech Support 5
P Laptop Tech Support 2
D Laptop Tech Support 1
S Laptop Tech Support 1

ASK THE COMMUNITY

TRENDING THREADS