GeForce GTXm black screen on game startup

Timbao

Estimable
Dec 1, 2015
2
0
4,510
0
Hi,
I have Win10 newly installed updated - all the drivers installed from ASUS site. The Notebook is N551JW. Integrated graphics is working but the GeForce is not - when i try to start the game or a program that should use the card the screen is black (or the part of the window that needs to render video) - the sound can be heard but the screen is black. I think this is a Win10 issue but i don't know how to solve it.

Tried rolling back the drivers - updating them - tried to do stuff with Nvidia control panel but to no success. Sorry if i missed the forum for this question.

Thanks for the help

Asus N551JW Notebook
Asus GTX 960m
Windows 10 pro 64bit
 
Hi,

Please do try these steps that may help in solving the issue.
- Go to Device Manager and uninstall NVIDIA graphics.
- Open Program and Features then uninstall anything related to NVIDIA graphics.
- Download and install the latest driver there is.
- Here's the link: nvidia.com/download/index.aspx.
- Reboot the laptop once installed, then after the restart make sure to set your games to run using NVIDIA processor in NVIDIA Control Panel.
 

Timbao

Estimable
Dec 1, 2015
2
0
4,510
0


Tried it - same result - black screen - sound and even the mouse pointer is from the game but the screen is black.
Drivers are 359.06

 

MatSymon

Estimable
Dec 9, 2015
1
0
4,510
0
I have exactly the same problem. I can't play any games. Always black screen with sound on startup.
I just bough a laptop with windows 10 x64 installed.
It is an Acer VN7 592G 700E.
Specs are:
Intel i7 6700HQ 2.60Ghz
16Gb Memory
GeForce GTX 960M

Please need some help. Thanks
 

TheBookIsBetter

Estimable
Jan 27, 2016
1
0
4,510
0


Did you ever find a solution? I'm having the same issues.
 

Stellarheim

Prominent
Mar 15, 2017
1
0
510
0
If you have a black screen on game startup, but hear game sounds, go to your integrated graphic card options and turn off Vsync (or set to application preferred). For intel it would be Intel HD Graphics Control Panel (something like right click on desktop > graphic settings > advanced mode > 3d graphics)
 
Thread starter Similar threads Forum Replies Date
s1b1 Laptop Tech Support 0
G Laptop Tech Support 1
M Laptop Tech Support 1
D Laptop Tech Support 0
GogetaBlue42 Laptop Tech Support 1
G Laptop Tech Support 4
J Laptop Tech Support 1
M Laptop Tech Support 1
K Laptop Tech Support 1
S Laptop Tech Support 7
N Laptop Tech Support 3
A Laptop Tech Support 10
J Laptop Tech Support 11
S Laptop Tech Support 1
T Laptop Tech Support 1
K Laptop Tech Support 1
P Laptop Tech Support 2
W Laptop Tech Support 1
H Laptop Tech Support 11
N Laptop Tech Support 1

ASK THE COMMUNITY