home audio system only playing left side speakers

Jul 16, 2018
1
0
10
0
I just moved into a new house with home audio set up. There is a Yamaha receiver with a Monster Cable multi-speaker selector. all speakers are hooked up to the Monster multi-speaker selector but only the left side speakers are playing. I looked at the balance on the receiver and ruled that out. does anyone know why only the left side speakers in all the zones are playing?
 
Try another source. Use the radio if there is an antenna connected.
Try connecting the left speaker wire to the right input on the speaker selector. If the right speakers now play then the problem is either the cable itself or the right channel on the receiver.
If not then there might be problem with the selector. They usually contain resistors that are used to present a higher load to the receiver so you can safely play more than 1 or 2 pairs at the same time. These can blow out. You can usually see burnt resistors if you open the speaker selector,
 
Try another source. Use the radio if there is an antenna connected.
Try connecting the left speaker wire to the right input on the speaker selector. If the right speakers now play then the problem is either the cable itself or the right channel on the receiver.
If not then there might be problem with the selector. They usually contain resistors that are used to present a higher load to the receiver so you can safely play more than 1 or 2 pairs at the same time. These can blow out. You can usually see burnt resistors if you open the speaker selector,
 
Thread starter Similar threads Forum Replies Date
R Audio 10
gorilaz2003 Audio 3
D Audio 2
B Audio 5
4 Audio 1
A Audio 2
J Audio 4
B Audio 4
L Audio 2
Tg123456$&@ Audio 3
J Audio 2
R Audio 3
B Audio 3
O Audio 14
S Audio 8
L Audio 1
Z Audio 2
S Audio 1
E Audio 20
MrGroggle Audio 2

ASK THE COMMUNITY