How do I connect my receiver to my PC and get 5.1 surround sound?

Status
Not open for further replies.

TheTenaciousOtaku

Estimable
May 23, 2014
30
0
4,590
1

Eduello

Estimable
Mar 2, 2014
472
0
5,260
94
Two options:
1. Use the optical S/PDIF output of your motherboard.
2. Use the HDMI output of your GPU. (This is what I'd recommend if you're using a HDMI display).

Go to control panel>sound>playback devices
For option 1, connect the cable and set the 'Realtek digital output' as you default device, then right click it, go to properties, and in the rightmost tab select DTS or Dolby Digital or 5.1 (or something like that).
For option 2, connect the HDMI cable through the receiver and set the 'Nvidia HDMI Output' as your default device. Then click 'Configure' and select 5.1.
 

TheTenaciousOtaku

Estimable
May 23, 2014
30
0
4,590
1
I already have 2 HDMI cables hooked up to my graphic card. 1 for my monitor and 1 for my TV...

Also, I tried the Fiber Optic method, but when I go to the properties tab I only have options for 2 channel audio
 

Eduello

Estimable
Mar 2, 2014
472
0
5,260
94
In that case you must unplug the HDMI cable from your monitor or TV, plug it into the receiver, and then plug a cable from your receiver's HDMI output to your TV/monitor (whichever you unplugged it from).
 

TheTenaciousOtaku

Estimable
May 23, 2014
30
0
4,590
1
So I would take the HDMI from my TV and plug it into one of the black HDMI ports on my receiver.

Then I'd have to buy another HDMI cable and plug one end into the TV and the other into the white HDMI 'out' port.

Is that right^? Will I still be able to switch monitors and be able to watch movies from my PC on my TV?
 

TheTenaciousOtaku

Estimable
May 23, 2014
30
0
4,590
1
I tried the optical cable in both the ports of my receiver and both times I went to the properties tab of the Realtek Digital Output, I get a list full of "2 channel". No 5.1
 

Eduello

Estimable
Mar 2, 2014
472
0
5,260
94
I'm fairly sure it'll work; I used to run a 7.1 setup with a Denon AVR-1911 and a 42" Panasonic TV from a laptop with a GeForce GT9600m and even that card was able to output 7.1 DTS-HD master audio :D
 

TheTenaciousOtaku

Estimable
May 23, 2014
30
0
4,590
1
It'll be a few days until I get an HDMI cable. In the mean time, could you tell me which input your receiver would be on when you wanted to listen through it?

The input options I have are,
- HDMI 1
- HDMI 2
- HDMI 3
- HDMI 4
- AV 1
- AV 2
- AV 3
- AV 4
- AV 5
- AV 6
- Audio
- Tuner
- Airplay
- USB
- V-AUX
 

TheTenaciousOtaku

Estimable
May 23, 2014
30
0
4,590
1
The cabling came today.

It seems I made a number of mistakes with my hardware description.

Corrections,
- The monitor is connected to the computer via a VGA connection (VGA to GPU/HDMI to monitor)
- The T.V is also connected to the computer via a VGA connection (VGA to GPU/HDMI to T.V)

I've currently got the following set-up,
- VGA/HDMI cable from GPU to HDMI 1 input on receiver
- HDMI/HDMI cable from receiver output to T.V input.

The result is an extended display to my T.V. Although this is horrible for watching video on the T.V as the video becomes very choppy. I switch to projector mode like always and it works perfectly.

I do have 1 gripe though. I'm really not liking the extended display. My mouse keeps moving out of the monitor and into the T.V. -.- Is there a method that doesn't involve an extended display? Or a way to lock the the extended display? Wouldn't an extended display always lower the GPU power I get for gaming on the monitor?

-Edit-
I forgot to mention that in the control panel-sound window, in the playback tab, the only available devices are the TV and monitor. I did try connecting the receiver directly to the GPU, after which my receiver appeared in the playback devices. But now that I've got the TV connected, the receiver option in the playback devices list is grayed out. Is it ok to have the TV selected as the playback device? It doesn't have a 2.1 or 5.1 options in the advanced tab. Only 16 - 24 bit audio options. I can't get Realtek Digital Audio to work either.
 

Eduello

Estimable
Mar 2, 2014
472
0
5,260
94
The 5.1 options are not in the advanced-tab with the HDMI connection. In the main playback window, left-click the output you are using once, then while it's highlighted, click configure in the lower left corner of the window. This should allow you to make your speakers 5.1.

The extended display will not necessarily lower your gaming performance by more than a few fps, but if you don't like it, try using it to just show the same stuff that your monitor shows (mirroring).
 

TheTenaciousOtaku

Estimable
May 23, 2014
30
0
4,590
1


The duplicate option is exactly what I wanted. You have earned yourself best solution and I believe this thread will come in very handy for future reference. Thanks a ton for your patience.

 
Status
Not open for further replies.

Similar threads