RubieRuub

Estimable
May 1, 2014
1
0
4,510
0
Hi guys, so I want to jailbreak my 2/3 year old PS3 Slim. So I know that you need to downgrade your current software version (In my case 4.55) to 3.55 and then update to 4.55 again but then with a jailbroken version of 4.55 or something else. But I heard you need E3 Flasher to downgrade your PS3. Is there any possible way to downgrade my current 4.55 without E3 Flasher or Progskeet or anything like that. Just with software? Or is it that you only need E3 Flasher for the Old fat PS3 and there is another possible way for the PS3 Slim?

Thanks for helping me out!
 

vortical

Estimable
Jun 6, 2014
16
0
4,590
7


There used to be other options for previous firmwares, but any firmware after 3.74 (i maybe mistaken as to the exact version ) requires external hardware to jailbreak. Also i suggest you correct your post so that you arent saying that you plan on doing said jailbreaking personally or the mods will likely delete the post.

 

ASK THE COMMUNITY