Question How do i make my dell xps 15 9550 use its dedicated gpu

Feb 12, 2019
2
0
10
0
So recently my laptop wont run aaa games like before such as fortnite i would get about 90 frames but now im getting 12. So i checked what was going on and the problem was that my laptop was automatically switching from gpu to igpu back and forth. i have tried everything i cannot get the same results as i used. I have even tried to go on invidia control panel and set the 3d Settings to high performance gtx 960m. But the problem still is on going. Plz help!!
 
It should not be running the game on the other card if you have set the Nvidia one to be the one you want used. Unless there are problems with that GPU. Try setting it as the default and see if this helps. If not, then you may want to try updating the drivers. Should even that not help, then I would start monitoring the temps to see if it is overheating.

Here's the steps on how to set it to default.

  1. Open the "Nvidia Control Panel".
  2. Select "Manage 3D Settings" under 3D Settings.
  3. Click on the "Program Settings" tab and select the program you want to choose a graphics card for from the drop down list.
  4. Now select "preferred graphics processor" in the drop down list. (You can see what the automatic option is listed as global setting) If you want to use the dedicated graphics card, select High-performance Nvidia processor.
Once it is running on the right one, test the system again and see if the problem persists.
 
Reactions: Ghaffar.dosti
Feb 12, 2019
2
0
10
0
It should not be running the game on the other card if you have set the Nvidia one to be the one you want used. Unless there are problems with that GPU. Try setting it as the default and see if this helps. If not, then you may want to try updating the drivers. Should even that not help, then I would start monitoring the temps to see if it is overheating.

Here's the steps on how to set it to default.

  1. Open the "Nvidia Control Panel".
  2. Select "Manage 3D Settings" under 3D Settings.
  3. Click on the "Program Settings" tab and select the program you want to choose a graphics card for from the drop down list.
  4. Now select "preferred graphics processor" in the drop down list. (You can see what the automatic option is listed as global setting) If you want to use the dedicated graphics card, select High-performance Nvidia processor.
Once it is running on the right one, test the system again and see if the problem persists.
#3
Thanks webworkings ive tried everything u said before, and thank you for you help but i cannot seem to find the problem. But i do think my laptop gets overheated to very high temperature, such that it burns my hands or my lap like 10 mins after i turn it on
 
Well if it is getting that hot, then that is likely your problem. Which, if not fixed, could lead to the GPU, if not more, getting fried.

If it is under warranty, I would have it looked at. If it isn't, then you can try cleaning it out (dust, debris, etc.) and make sure the vents are clear. If that doesn't do enough then it would be time to look to see if anything needs to be repasted, or even replaced (fan, GPU, motherboard, etc.).
 
Thread starter Similar threads Forum Replies Date
A Laptop Tech Support 1
S Laptop Tech Support 1
B Laptop Tech Support 1
K Laptop Tech Support 3
J Laptop Tech Support 4
S Laptop Tech Support 1
T Laptop Tech Support 2
C Laptop Tech Support 3
E Laptop Tech Support 1
E Laptop Tech Support 1
T Laptop Tech Support 14
K Laptop Tech Support 1
L Laptop Tech Support 3
P Laptop Tech Support 3
V Laptop Tech Support 1
V Laptop Tech Support 2
J Laptop Tech Support 11
N Laptop Tech Support 3
R Laptop Tech Support 1
R Laptop Tech Support 2

ASK THE COMMUNITY