How to boot after deleting uefi partifion on hp Envy X2


Dec 30, 2017
Product Name: Envy x2 (HP Envy 11-g010nr )
Operating System: Microsoft Windows 8.1 (32-bit)
Hello everyone,
I want to install Linux on my Enxy X2 (HP Envy 11-g010nr )and I have tried everything. However, due to some incompatibilities it's practically impossible to achieve.I though it would be possible to delete the uefi partition, install linux and then windows in a dual boot setup. However, after deleting the uefi partition and extending the primary partition, the computer starts up to the message:

Boot Device not found
Please install an operating system on your hard disk
Hard disk (3F0)

Unfortunately there is no way to enter System Recovery either by pressing F2, F11 etc.
F2 brings you to some memory and hard disk diagnostics which are of no use in this case.

I have entered the BIOS menu and restored to defaults but nothing changes. Still boots to the above menu
I have used bootable usb stick and sd card with DOS/Linux to boot but the computer does not seem to recognise these. I have disabled secure boot as well but still nothing.
In the Bios, I cannot access the Boot order menu either - it's kind of greyed out.

So I am basically locked out of any OS, command prompt or anything I can type commands into.
I have tried all the HP recommend troubleshooting guides but nothing works because I cannot access recovery

Any ideas?
Thanks for reading
You can't access recovery because you messed with the default partitions, and the recovery programs rely on them to run the recovery.
You either need to contact HP to get a set of restore disks or download Windows and run the setup yourself. Not sure if they still have 8 for download, but they do 10, and you can either use a DVD or a USB stick there.