HP 15-R213NA (Refurbished) - Won't power on

Gazza2907

Estimable
Jun 5, 2015
1
0
4,510
0
When plugged in with the battery OUT it gives a solid white power LED, plugged in with battery IN gives solid orange light, power button changes to solid white, still doesn't power on.

When power button is pressed the power light flashes white and the wifi button light flashes orange, further presses do nothing until battery pulled and unplugged.

Checked charger with a multimeter; gives 19.5V, but only shows up to about 0.3A (in bursts). I don't know if it's possible to measure current accurately in this way, though? Going to leave it charging for the rest of the day, so if it is providing a small current it should be able to charge the battery, and I will test it later.

Thoughts?


Thanks
 
Hi,

Have you tried removing the battery and use just the AC adapter for it? Also perform a hard reset since the laptop seems to be in a Hibernate mode. Remove the battery and the AC adapter off it then press and hold the power button for 20 secs. Put everything back together then turn it on and it should load properly into windows.

About the voltage of your laptop, 19v is the standard voltage for most of lithium cell batteries.
 
Thread starter Similar threads Forum Replies Date
S Laptop Tech Support 1
A Laptop Tech Support 1
S Laptop Tech Support 1
S Laptop Tech Support 1
C Laptop Tech Support 1
R Laptop Tech Support 4
G Laptop Tech Support 3
Z Laptop Tech Support 3
K Laptop Tech Support 2
J Laptop Tech Support 1
D Laptop Tech Support 6
M Laptop Tech Support 1
S Laptop Tech Support 5
G Laptop Tech Support 2
R Laptop Tech Support 3
B Laptop Tech Support 5
M Laptop Tech Support 5
A Laptop Tech Support 5
B Laptop Tech Support 2
C Laptop Tech Support 4

ASK THE COMMUNITY