Solved! HP laptop problem - this is the story - please help

Feb 27, 2021
2
1
15
0
Hi All, I'll try keep it as brief as possible.
The Story....
Laptop stopped working. Took it to repair shop. They said motherboard not working and better to buy new laptop. They took hard drive out and put into caddy/encloser with usb cable. Said if I get another laptop just plug encloser into usb and should display my name, then click on that to open and copy files onto laptop.
But.,.. I managed to buy a new motherboard, exactly same as the original with matching part numbers etc. As I know nothing about the inside of a laptop I took a pic before I disconnected the old board so I could get everything connected correctly on the new one. There was no internal battery so I got a new one also.
The Problem.....
Switched the laptop on and got the HP logo screen as usual, then the lock screen image page, then the admin page with password required. The cursor in the password box only flashes a few times instead of constantly. When I try to type in my set password no letters/stars appear in the box. I've tried with the HDD left in the enclosure and connected to laptop via usb. I've also tried with it out of the enclosure and plugged back into it's place in the laptop. I've tried things I read about online like continually pressing the ESC key and F10 to open BIOS, holding down m/s key and various other keys, etc etc. I can get a page with options like 'Troubleshoot' , ' Restart' , "Reset pc'. I clicked on 'reset pc and keeping my files' with the HDD back in the enclosure. It went through the procedure taking a couple of hours including reinstalling Windows 10. I Powered up the laptop hoping everything would work now but it was still the same as mentioned above, got to the admin page but couldn't put in the password. By the way the laptop is powered directly with the charger as the big battery is u/s.
I hope I've detailed the problem enough for someone out there to help. Thanks.
 
Reactions: Hydra119
Feb 27, 2021
2
1
15
0
Should be able to go to settings in BIOS, and disable the requirement to need a password, on starup.

BTW, the object that you call an enclosure is called a "dock", too.
Thanks for the reply.
Are there a number of ways to get into the bios. I tried the method I mentioned, of continuous pressing ESC with the screen blank and then f10 when it starts but it didn't work.
 
Thread starter Similar threads Forum Replies Date
Belltozar Laptop Tech Support 0
abdullahmert Laptop Tech Support 3
cvs4321 Laptop Tech Support 1
Z Laptop Tech Support 2
SSGB8 Laptop Tech Support 0
Enaodaro Laptop Tech Support 1
Lucc1ano Laptop Tech Support 1
Anderdid Laptop Tech Support 13
L Laptop Tech Support 3
L Laptop Tech Support 0
D Laptop Tech Support 2
S Laptop Tech Support 1
M Laptop Tech Support 0
seabromd Laptop Tech Support 0
aecanive Laptop Tech Support 0
Maclik_M Laptop Tech Support 11
70UNIK Laptop Tech Support 0
N Laptop Tech Support 5
AbhiramReji602 Laptop Tech Support 1
L Laptop Tech Support 3

ASK THE COMMUNITY