Lenovo Y50 Micro FPS drop/lag spike in League of Legends

icyshiver

Estimable
Jul 12, 2014
1
0
4,510
0
Hi everyone,

I just bought my lenovo Y50 15"6 fullHD LED non-touch:
Intel Core i7-4700HQ
8GB (2x 4096MB) - DDR3, 1600MHz
NVIDIA GeForce GTX 860M (4GB GDDR5, GM107)
8GB SSD +1TB (1000GB) 5400rpm SATA
Wi-Fi 802.11ac

First thing I installed Win 7 x64 and of course encountered the issue with nVDIIA drivers, but thanks to some forum communities I found the solution.
Then I installed all the other drivers recommended from Lenovo website, updated the Windows, installed couple of basic apps/programs and thought everything should be fine. Well, I guessed ALMOST correctly. Indeed I haven't seen any major problem so far, but there is this one issue, which annoys the hell out of me:

When I play League of Legends, every single match, randomly I receive lag spikes/freezes for 0.5s. It's just very irritating and frustrating. It's so tiny, but yet so disturbing and it doesn't happen rarely, oh god, it happens all the time. I don't know if you ever have played it, but let me draw you the picture: While you move your character across the map, sometimes he just shows up to a different location than you sent him, something like he was teleported to a small distance, it can happen in a fight of course. It's either FPS drop or lag spike. However, I have been monitoring it while the problem appears. It shows 60 FPS permanently, no matter what graphic quality I choose, or how loaded the system is. But it's the same with the ping as well... when the micro freeze/lag happens , the ping is unchanged.

I thought it was a network issue, since the ping was going up and down(but not when the lag/freeze happens). BUT on my previous laptop, I didn't and still don't have this issue. Which made me think it might be the Wi-fi driver, so I installed the last version from Intel, unfortunately the issue still persists.

I even typed the times when the micro lag spikes happened and then checked the event viewer: nothing was correlated...

And the power options are set to high performance.

I also tried with Ethernet cable connection, the result is the same....


Any ideas ? Thanks in advance!

P.S. It only happens in this game, for example in Path of Exile I don't have any lag spikes/freezes
 

AntIV

Estimable
May 17, 2014
2
0
4,510
0
I too, have just purchased my Lenovo y50 and received it in the mail. I installed league of legends, played a match and the same problem you described happened during my game. My fps will only stay at a set 60 and during an encounter or team fight my game would slow down for a quick second then come back. Not sure what to do with this. Hopefully someone can help.
 
Thread starter Similar threads Forum Replies Date
len-flex-3 Laptop Tech Support 1
K Laptop Tech Support 2
V Laptop Tech Support 5
S Laptop Tech Support 1
M Laptop Tech Support 8
B Laptop Tech Support 1
farhan.sidiqui Laptop Tech Support 3
J Laptop Tech Support 1
RnCL Laptop Tech Support 1
J Laptop Tech Support 0
ruslruslrusl1 Laptop Tech Support 3
So.Sona Laptop Tech Support 7
clodneedshelp Laptop Tech Support 1
Xyresix Laptop Tech Support 1
E Laptop Tech Support 5
L Laptop Tech Support 3
Pippin1829 Laptop Tech Support 3
Shadowz21ro Laptop Tech Support 1
MasterLewis Laptop Tech Support 1
B Laptop Tech Support 1

ASK THE COMMUNITY