Lenovo Y50 -- Replaced hard drive with new SSD, now having WiFi driver issues

straynode

Honorable
Sep 20, 2012
11
0
10,560
0
Hello,

I recently purchased a Lenovo Y50 and replaced the hard drive with a Samsung SSD. Initially, I cloned the original drive on to the new SSD and everything was fine. Then I attempted to perform a factory reset and was told that I didn't have the recovery media.

Apparently there is a recovery partition on stock Lenovo hard drives that wasn't cloned over. So, I connected the original hard drive via USB and performed the factory reset successfully. Everything works great, except for one thing...

I am currently writing this post via my laptop and its ethernet connection. Every time I attempt to connect via WiFi, I am shown a "limited" connection.

The WLAN driver appears to be installed correctly, and my computer detects the right network. However, there is no connection.

Your help is much appreciated!
 

straynode

Honorable
Sep 20, 2012
11
0
10,560
0


I did as you said, but the problem persists. I was previously able to connect to WiFi on the original hard drive; in terms of hardware, nothing else has changed. The wireless component is still inside my laptop and it detects available networks. There must be something I can do, right?
 

straynode

Honorable
Sep 20, 2012
11
0
10,560
0


Alright, I bought the USB adapter. Will report back when it arrives!
 

Dealer of Aces

Estimable
Jun 23, 2014
7
0
4,510
0
Another option is if you still have the original hard drive with your old data on it you can purchase a usb to sata cable over amazon. I purchased one for 15 and cloned my OEM hdd to my new samsung 840 evo and it worked perfect. I didn't have to reinstall anything. Hope this helps. Your old wifi should not have been damaged so you shouldn't need a usb wifi adapter for it to work properly.

(I have the same laptop)
 

kRx

Estimable
Jul 20, 2015
1
0
4,510
0
I just experienced the same thing.

I have a Samsung NP305U1A. I successfully cloned my 500GB HDD to a Samsung EVO 250GB using the provided Samsung Data Migration software. Everything went well and booted flawlessly. On the new SSD, I noted my WIFI connection detects the 2 Wifi networks in my house but COULD not establish the connection. I even performed a Factory reset/recover of the laptop on the SSD already and this did not work either. At this point I bought a USB wifi adapter, and I was able to download newer driver for my Wifi device, again this did not solve the issue. After this, I removed my SSD and installed my OEM HDD, and there the OEM WIFI device worked again.

Where is the problem here?

I thought that the Wifi device inside my laptop could already be physically damaged since even after a Factory reset it did not work. In fact it is the only one device that did not work after the factory reset using Samsung recovery solution.

Thankyou.
 

Danish Viking

Estimable
Aug 8, 2015
2
0
4,510
0
I ended up in this thread because I have odd problems regarding my own T520 and a Intel ssd originally from an Lenovo X540. Cant reboot but no problems with close and power on. Very wierd.

Based on what I read here I think that some kind of radiation from the disk could be the problem. Does it sound plausible? I dont know but some of Lenovos disks is mounted in a little bag made of cardboard and alufoil.
 

digitaldoc

Distinguished
Herald


Can you describe in more detail what are the odd problems with the notebook?
 

Danish Viking

Estimable
Aug 8, 2015
2
0
4,510
0
My post was supposed to be an answer to "Straynode". Not to start a new problem :)

The "odd" thing about my T520 is that it boots and works fine, but it cant reboot (cant see the disk). I have to shut it off and then on to work. PC and disk F/W is up to date and the disk is an original Lenovo (actually Intel opal drive) from an x540.

In the (very) old days one could have timing issues on a rotationdisk if it had a large number of plates but that cant be the reason here. Normally I'm not that easily fooled. Maybe the disk is too modern :)
 
Thread starter Similar threads Forum Replies Date
A Laptop General Discussion 1
A Laptop General Discussion 1
bob2341 Laptop General Discussion 1
D Laptop General Discussion 1
R Laptop General Discussion 3
mqb2766 Laptop General Discussion 1
Lutfij Laptop General Discussion 0
E Laptop General Discussion 5
S Laptop General Discussion 1
S Laptop General Discussion 2
S Laptop General Discussion 6
B Laptop General Discussion 3
X Laptop General Discussion 1
M Laptop General Discussion 1
P Laptop General Discussion 1
M Laptop General Discussion 6
C Laptop General Discussion 2
N Laptop General Discussion 8
M Laptop General Discussion 3
C Laptop General Discussion 1

ASK THE COMMUNITY