Question Lenovo Yoga 920 Battery

Jun 19, 2019
9
0
10
0
Hi,
I'll stay positive although I don't think I'd buy a Lenovo product again. I'll work on the battery first. It died badly just after 1 year and not much use. Lenovo support said buy a 3rd party battery - which I bought & installed the same as original. It gives a bit over 4 hours of basic use (browsing, email, word & XL docs) and less under a bigger load. If I shut the machine 'off/down' a 100% charged battery dies in a few days. If I disconnect the batter, it has about 98% left in a few days. I've turned everything off I can find. Any solutions? Certainly doesn't give anywhere near the original specs or what the original battery gave. I'd be happy nearing 8 hours of basic use. Thanks in advance.
Intel Core i7 1.80GHz 16GB 64 Bit WIN10 Pro Pen and touch support
 
Are any USB devices or external devices connected to the laptop while off?

Restart the laptop and shutdown after it started up.

Before going ahead, try a BIOS update first:
https://pcsupport.lenovo.com/us/en/products/LAPTOPS-AND-NETBOOKS/YOGA-SERIES/YOGA-920-13IKB/downloads/DS500735

Disable fast startup in windows 10:
https://www.tenforums.com/tutorials/4189-turn-off-fast-startup-windows-10-a.html

Are all drivers installed? Especially Intel management engine (IME), chipset and ACPI/ATK drivers
Let the Lenovo Vantage app do this. I´m not a fan of bloatware, but in this case it might be useful.

Also have a look at this:
https://forums.lenovo.com/t5/Lenovo-Yoga-Series-Notebooks/Yoga-920-battery-drain-after-shutdown/td-p/3958117
 
Jun 19, 2019
9
0
10
0
Hi,
Thanks for this.
This has been ongoing for some time & up to today is still happening.
From Saturday Morning to Monday Morning the battery totally drained.

There are No USB devices or external devices connected while the pc is off / or on for that matter.
(WiFi is the exception although I've turned that off before)

I did turn off the Always On USB - But found that it was 'on' again when checked the other day.
Turned if off again.. No Help

BIOS - I requested an update through Lenovo Vantage months ago (Version 5NCN41WW) when this started to happen. No Help
(Actually did this because I lost my Sound (No Audio Output Device is Installed After a Win 10 Update)
That's another story / hurdle to conquer once I can get the batter working properly.
(I'm not technical but would be crazy if these issues were related)

ACPI Driver says installed and Working properly. Update showed I have the latest version (Winbuild. 160101.0800)

ATK - Not sure where to find it but I installed it from the Lenovo download.
In FN and function key Properties / General says No Drivers are installed for this device / Driver Tab says there is a
Lenovo Version: 9.0.4.3 Driver. I requested an update and rebooted. Still General & Driver Details Box/Link
shows No Drivers are installed for this device

This seems strange and the fn keys are not working to get in to the BIOS

Disabled Fast Start Up a while ago. - No Help

Bottom line is when the pc if shut down, the battery goes down by roughly 5% per hour (in the first few hours)
And is 0% within 2 days. (The battery seems to hold a virtual 100% charge when not connected)

From your other Forum link.
I re-installed Intel Management Engine

Any ideas from here?
 
Jun 19, 2019
9
0
10
0
YES, it's a full activated license.
Which is why it did an auto update and suddenly my sound card was not recognisable..
Again.. another issue. But my Battery started to pack it in around the same time.

This is an ongoing issue(s).
I got the new battery in April.
Tried to train it every which way.
The Battery supplier is willing to take it back to test it - which I'm about to do but hoping someone had
an answer before I did.
I really don't think it's the battery since it holds it's full charge over a few days when NOT connected to the
laptop.
 
really weird.
Which battery is it exactly now? And what specifications does it have: Wh, mAh and voltage
Did you damage/unplug anything inside the laptop while replacing the battery? Recheck the connections inside.


reinstall all drivers from the Lenovo homepage

reset the laptop, first the hardware (load default BIOS setting) and eventually reset the cmos by removing the cmos battery inside the laptop

reset windows

also charge the battery completely and try PCmark 8 battery simulator. You should get about the same time like in this review (4 hours):
https://www.techradar.com/reviews/lenovo-yoga-920-review/2
 
Last edited:
Jun 19, 2019
9
0
10
0
Appreciate your help / time.

Battery is Badged as the
Lenovo TIS 2217-2548
Made by Lenovo (Thailand) Limited
Manufactured by Simplo Technology (China)
Has virtually all the same markings

NO Damage.. very careful
Connection is easily in / out with a small pull

What constitutes 'All Drivers'

Had reset the BIOS to default

I'll try the CMOS - Haven't had any issues with Dates / Times / Etc..
Reset Windows.. So basically start again.
I honestly think I did this some time ago with the help of Microsoft Support.

I've downloaded PCmark 8 - Try that next week.

I used to get a full day out of the battery when first bought.
Then it started to drain quickly and not take as large of a charge.
And - It didn't drain so much overnight when turned off.

I would get 4 hours but that's about it and that's when it's just sitting there 'on'
None of the reviews I read mentioned such a short life per charge.
Think it'll be back to MAC and bootcamp.

Now.. only if I could get the sound to work - Which a class action has been filed against Lenovo for.
These are not one-offs and clear issues with the product.
Lenovo then fluffs people off and blames the drivers, etc.

Apart from a 4 hour battery life, a battery that loses 50% of it's charge overnight, no sound and poor ongoing support.
This is a well designed device.

Cheers and Thanks again.
 
the original battery should have 70Wh, the replacement only has about 50Wh, which would explain the difference.

The replacement battery should be compatible to these numbers, all of these have 70Wh:
5B10N01565, L16C4P61, L16M4P60

Doesn´t the sound work via the speakers and the headphone jack? Is the volume control available in the bottom right of windows? Is the default audio device set to speakers?
Is the realtek audio device visible in windows device manager? Is a question mark or exclamation mark there?

Any cables jammed while assembling the battery back in?
top left and right screws: https://d3nevzfk7ii3be.cloudfront.net/igi/QiMFZPM26PIKefg3.huge

https://pcsupport.lenovo.com/uu/en/products/LAPTOPS-AND-NETBOOKS/YOGA-SERIES/YOGA-920-13IKB/downloads/DS540001
 
Jun 19, 2019
9
0
10
0
Thanks again.

Sound was an issue before the battery.

Re battery. It's exactly the same as the original.
Rating: 7.68V TYP9120mAh / 70Wh MIN 8860MAh / 68Wh

I think I'm at the point where I'm going to send the battery back for testing.
BUT - It holds the charge when not connected - So something is draining it.
It is an older date (near the barcode) than the original battery so that 'could' be a little bit of the issue.
BUT - per above.. why it gets drained? And then why would my 'newer' (original) battery die so quickly.

Maybe should start a separate thread or give you my direct email contact?
Sound: It is not recognizing a sound card. I've had Realtek and Intel Sound drivers.
right how with the Realtek the sound icon has a red X and says "No Speakers or Headphones are plugged in"
When is has the Intel(R) drivers it says "No Audio Output Devices Installed"

In Device Manager / System Devices: (now with the RealTek Driver)
High Definition Audio Controller Properties
General / This device is working properly
Driver / Microsoft 14SEP18 Version: 10.0.17763.1

If I delete the ReakTek Driver the Intel(R) SST.... automatically download and the Red X message changes as noted.

In Device Manager / Sound, video and game controllers
I know have 2 drivers listed there.
High Definition Audio Device
General tab / This device is working properly
Driver / Microsoft 14SEP18 Version: 10.0.17763.1
Events / Has some time stamps where I've been trying to get it to work, then.
Events Tab / Information /
Device HDAUDIO\FUNC_01&VEN_8086&DEV_280B&SUBSYS_80860101&REV_1000\4&2630e0a4&a&0201 requires further installation.


Also In Device Manager / Sound, video and game controllers
RealTek high Definition Audio (SST) (With a ! (and orange triangle caution sign)over the speaker icon )
General tab / Device Status: This device cannot start. (Code 10)
The request is not supported
Driver tab / RealTek high Definition Audio (SST) Version: 6.0.1.8202
Events tab / Information /
Driver Management has concluded the process to add Service IntcAzAudAddService for Device Instance ID ROOT\MEDIA\0000 with the following status: 0.
Also in Events it says MMC could not create the snap-in
 
Jun 19, 2019
9
0
10
0
I bought battery online.
1 x Replacement for LENOVO YOGA 920-13IKB 5B10N01565 L16M4P60 7.68V 70WH
Laptop Battery (NBLE596)

I loaded Ubuntu. Sound icon doesn't have an X on it but nothing is playing in speakers or earphones.
 
Jun 19, 2019
9
0
10
0
The hardware malfunction is a Lenovo fault and happened before the Battery started to go.
So far as I know. Could have been around the same time.

Which is why there is a class action in the USA.
Lenovo already settled a class action regarding WiFi connectivity issues. (Dragged there feet on that one too)
And now have one in progress re the Sound cards - apparently frying.

You can see there are other investigations regarding Lenovo products. - Wonder why this is not taken in to
consideration when reviews on their products are undertaken. Surely a history of issues and unwillingness to
help their customers adequately should be part of a review process.
Personally, if I was doing a review on their products, I'd be giving a truthful proviso .. ** Note these issues / Buyer beware.

The Legal firm has asked me for information on my situation but being in
Australia, I cannot take part.

Do you know if there is a way to resent the MB Chipset?

Thanks to Lenovo, I have a $2500 laptop where the battery
runs out before I can see the end of a "Silent Movie".

Do appreciate your help / persistence.
 
Just a thought:
In windows, did you try the media buttons? F1, F2, F3 for mute, volume up and down (eventually you will have to use the FN button together with the F keys)

some more thoughts:
https://support.lenovo.com/au/en/solutions/ht501860

I fixed that second problem via the following steps. (Although the directions are different, this video tutorial from minute 1:38 or this webpage tutorial give good images of the following prompts you will see.)

4) After reboot select Troubleshoot\Advanced Options\Start Up Settings\<Restart>

5) Choose "Option 7: Disable Driver Signature Enforcement"

6) After booting into Windows, I received an error message about the LenovoUtilityUWP.

(Note: Even when I ran "sigverif.exe", the LenovoUtilityUWP was not detected as being unsigned.)

7) You can disable the LenovoUtilityUWP in "Startup" or uninstall LenovoUtilityUWP in "Add & Remove Programs".

8) You may have to reboot one more time, but the sound should now work. :)
 
Last edited:
Jun 19, 2019
9
0
10
0
Have tried the F1, F2, F3. They don't do anything.
dg - When holding Fn, F1 opens the browser. F2 & F3 do nothing.

some more thoughts:
https://support.lenovo.com/au/en/solutions/ht501860
dg - I've tried all these many times.
The Realtek driver gets relaced by the intel(R) driver.
No help.

WIN10 Trouble shoot completes but says "was unable to automatically fis all the issues found.

Troubleshoot Report:
PROBLEMS FOUND: The speaker, headset or headphone is unplugged Not Fixed
There might be a problem with your audio device - Detected

One or more audio service isn't runnning
Both the Windows Audio and the Windows Audio End point Builder services must be running for audio to work correctly. Atleast (Sp?) one of these services
isn't running.

Audio device is disabled
The audio device you selected is currently turned off in Windows.

dg - BUT - In Services both AudioEndpointBuilder & Windows Audio Status' say Running

I fixed that second problem via the following steps. (Although the directions are different, this video tutorial from minute 1:38 or this webpage tutorial give good images of the following prompts you will see.)
dg- Is this for me? BSOD Error? or was that for someone else?

Are you wanting me to start in Safe Mode to try to disable something or is this mixed up with someone else?

Cheers & thanks
 
Thread starter Similar threads Forum Replies Date
M Laptop Tech Support 6
niv_p Laptop Tech Support 3
anclark Laptop Tech Support 0
S Laptop Tech Support 2
G Laptop Tech Support 3
E Laptop Tech Support 2
E Laptop Tech Support 0
C Laptop Tech Support 4
L Laptop Tech Support 1
R Laptop Tech Support 1
R Laptop Tech Support 1
V Laptop Tech Support 5
S Laptop Tech Support 1
C Laptop Tech Support 1
T Laptop Tech Support 3
V Laptop Tech Support 3
T Laptop Tech Support 1
U Laptop Tech Support 2
C Laptop Tech Support 2
K Laptop Tech Support 4

Similar threads


ASK THE COMMUNITY

TRENDING THREADS