Lenovo Z50-70 External monitor problem.

shamortiy

Honorable
Mar 22, 2013
4
0
10,510
0
Hi,

I have a Lenovo Z50-70 laptop(GeForce 840m 4gb, 8gb ram and i7).

When I plug in my external monitor using VGA cable, it starts to flicker every 3-4 seconds(like its losing signal to laptop). I have latest Intel HD and Nvidia display drivers installed. I tried to attach the same monitor to my old laptop and everything works fine, so its not cable or monitor problem. Also tried to remove laptop charger, changing display settings etc., and the problem still remains. Refresh rate for both monitors is set to 60hz and cannot be changed.
No idea what else can I do to prevent this permanently.
Interesting part: When I launch any game then flickering goes away. When I exit the game, flickering comes back. Its so weird.

Thank you in advance for your help.
 

shamortiy

Honorable
Mar 22, 2013
4
0
10,510
0


Already tried - same problem.
I think its problem with Intel HD Graphics, when I disable it or when any app starts using Nvidia then everything works fine. But its not a solution, because I cant use pc without Intel HD :/
 

shamortiy

Honorable
Mar 22, 2013
4
0
10,510
0


Hey. Still looking for fix. Temporary fix I found is launching GeForce experience and leave it open in background or any other program that uses nvidia card.
 
Thread starter Similar threads Forum Replies Date
C Laptop Tech Support 1
M Laptop Tech Support 5
T Laptop Tech Support 1
H Laptop Tech Support 13
M Laptop Tech Support 3
S Laptop Tech Support 1
H Laptop Tech Support 4
Mike Andronico Laptop Tech Support 1
B Laptop Tech Support 9
B Laptop Tech Support 1
P Laptop Tech Support 2
P Laptop Tech Support 1
C Laptop Tech Support 3
G Laptop Tech Support 8
J Laptop Tech Support 2
A Laptop Tech Support 1
L Laptop Tech Support 1
H Laptop Tech Support 3
S Laptop Tech Support 1
J Laptop Tech Support 2

ASK THE COMMUNITY

TRENDING THREADS