Medion Akoya Laptop wont, show any sign of life after battery went flat

Feb 7, 2018
4
0
10
0
The laptop ran out of charge and whilst doing updates I was away from home and didn't have the right charger, tried a couple of other but no charge... got home plugged in with the proper charger and now it won't show any sign of life, no charge light, no power on... I tried the rest but nothing.. Any suggestions? its a medion akoya s4613 and was running 100% fine prior to this.
 

ac13044

Commendable
Mar 25, 2016
42
0
1,610
9
then it could be the charger itself or the charging port. you would need to get a charger that is compatible with your laptop
 
Feb 7, 2018
4
0
10
0
I did open it all up, basically looking for a fuse or similar - nothing jumpd out at me I'll test it with the voltmeter tomorrow :)
 
Feb 7, 2018
5
0
10
0
Yeah it's never something apparent :lol:, I would try the reset again (remove battery and power adapter and hold the power button down to discharge)maybe even longer than 30 seconds and then plug in the adapter without battery first. I had a laptop that eventually got going after a few resets (battery was gone). But if you can verify the voltage is arriving to the MOBO then that eliminates port and power supply. Keep us posted.
 
Thread starter Similar threads Forum Replies Date
chippy-mx Laptop Tech Support 2
T Laptop Tech Support 2
A Laptop Tech Support 1
R Laptop Tech Support 1
L Laptop Tech Support 2
U Laptop Tech Support 2
M Laptop Tech Support 1
B Laptop Tech Support 1
W Laptop Tech Support 1
J Laptop Tech Support 2
J Laptop Tech Support 1
E Laptop Tech Support 1
N Laptop Tech Support 3
NOOB2PRO Laptop Tech Support 1
NOOB2PRO Laptop Tech Support 1
steven10101989 Laptop Tech Support 1
M Laptop Tech Support 4
L Laptop Tech Support 3
B Laptop Tech Support 3
A Laptop Tech Support 2

ASK THE COMMUNITY