lonelywizard

Estimable
Feb 24, 2015
5
0
4,510
0
So i tried 3 different microphones and 2 headsets...I can hear voices perfectly fine there is no problem there but when i try to communicate with my mic its horrible. People can barely understand me from the background static noise...And even worse i noticed that, the background voice exists even when i mute my microphone...this is the sound sample from a recording i took when my mic is muted:

https://www.youtube.com/watch?v=-Ge9naMM1Cg

i assumed it was because of my motherboard(Asus Z-170), tried my microphones on a friends computer and it worked in his PC just fine...I tried literally all sound drivers on the internet,tried a external sound card,made double sure my power outlet is grounded...nothing is helping me so far...Any advice?
 

bjornl

Estimable
Mar 16, 2016
399
0
3,060
156
Begin by checking your PCs grounding. Make sure it is well grounded. Buy one of those 5 buck circuit testers. Consider using a line filter.
The cheapest one I have tried which actually worked is this one:
https://www.amazon.com/dp/B003BQ91Y6/

Make sure your computer case is buttoned up. RF can leak out.
Check your monitor for RF (reposition the mic a few times).

Consider also adding a UPS like this one:
https://www.amazon.com/CyberPower-CP1350PFCLCD-Sinewave-Outlets-Mini-Tower/dp/B00429N19W?th=1
I'd condition the power before it hits the UPS.
 

lonelywizard

Estimable
Feb 24, 2015
5
0
4,510
0


280 $ for something that might not even fix my problem? That doesnt sound like something i can do without making sure tbh...

Besides, i already tried a UPS (TUNCMATIK LITE II 1000VA LINE INTERACTIVE UPS)
Made sure my power outlet is grounded as said before
And i've been suffering from this for months if not a year so yeah i repositioned my microphone more than a few times during those times...Anything else coming to mind?
 

br00n0

Estimable
Nov 18, 2015
13
0
4,570
3
Two options, maybe:

1- Instead of using the jacks on the front of your PC case, use those behind. They have shorter wires and are less prone to interference. Did that on my Asus desktop.

2- Buy a 10$ USB sound card and plug your headset in there. Did that on a problematic Alienware X51 and it works very well.

**OOPS, just saw that you already tried an external sound card. I'll leave my answer here anyway as it might come handy to others...**
 

tsnor

Distinguished
Nov 20, 2008
41
0
18,610
6
Skype has a very mature trouble-shooting section for microphones and changes many things correctly for you. Try getting the mic to work in Skype.

That's 60 cycle humm from a ground loop or really poorly set mixer controls. Get into "sounds" and mute any other input devices especially line in. Set the mic volume high so you are not highly amping a very weak signal.

What happened when you tried "..,tried a external sound card,.." same humm ?

 

lonelywizard

Estimable
Feb 24, 2015
5
0
4,510
0

Yeah tried all jacks :(
 

lonelywizard

Estimable
Feb 24, 2015
5
0
4,510
0

its less robotic and loud i'd say with external sound card...normal humm is 10/10 loud,external sound card humm is 8/10

yeah there was a "line in" under sound/recording section...disabled that, nothing changed...And using skype and discord daily...Or at least try to use with people who can bear that static noise
 
Thread starter Similar threads Forum Replies Date
K Audio 1
L Audio 3
T Audio 2
N Audio 4
Sithex Audio 1
S Audio 3
L Audio 1
S Audio 1
reshaydee Audio 3
B Audio 1
B Audio 1
I Audio 3
T Audio 2
V Audio 1
J Audio 5
A Audio 5
B Audio 2
T Audio 2
J Audio 1
dsr07mm Audio 1

ASK THE COMMUNITY