Question Microphone picks up breathing but not my voice

Jan 25, 2021
1
0
10
0
Yes, I've seen the thread on here for this. It doesn't help. I've tried playing with the setting and I have had nothing. On the other thread, there was a mention of a program that has influenced it. I've checked Realtek, Windows sound. I've changed ports and I've adjusted everything I can. Please help.

Btw, the model of the headphones are SOMIC G951S. I've tried installing the drivers but they do not work. I've downloaded the drivers from different sources and none of them work.
 

hang-the-9

Titan
Moderator
Next step, contact support for the headset to make sure it's actually working. Messing with drivers won't help you, you need the correct drivers for your computer. Did you test the headphones with other systems? They have a 4 pole and an adapter for dual 3 poles, if you have the adapter in use make sure it's seated properly, a lot of times people have it not clicked in all the way. Test them without an adapter on a phone or a laptop with a single connection.
 
Feb 2, 2021
1
0
10
0
It's probably only taking up your breath but not your voice is because your earphones/headsets' default microphone are actually the earbuds instead of the ACTUAL internal/external microphone your headsets or earphone is built with. Try having one of your earbuds on, and the other close to your mouth, and then try to talk. IF this is the case, then:

Go to Control Panel
Search up "Realtek HD Audio Manager" [you may or may not find this]
When you first open this Audio Manager, you will be greeted with 3 options:
a) Headsets
b) Speaker Out
c) Headphone

Click the one which you think is suitable for e.g Headsets for your headset, headphone for your earphones. It should work.



Note: if you can't find Realtek HD Audio Manager, you have to downgrade your Realtek Audio Driver to the version 2.81, which is sorta a lengthy process. You can search this up on YouTube.
 

hang-the-9

Titan
Moderator
It's probably only taking up your breath but not your voice is because your earphones/headsets' default microphone are actually the earbuds instead of the ACTUAL internal/external microphone your headsets or earphone is built with. Try having one of your earbuds on, and the other close to your mouth, and then try to talk. IF this is the case, then:

Go to Control Panel
Search up "Realtek HD Audio Manager" [you may or may not find this]
When you first open this Audio Manager, you will be greeted with 3 options:
a) Headsets
b) Speaker Out
c) Headphone

Click the one which you think is suitable for e.g Headsets for your headset, headphone for your earphones. It should work.



Note: if you can't find Realtek HD Audio Manager, you have to downgrade your Realtek Audio Driver to the version 2.81, which is sorta a lengthy process. You can search this up on YouTube.
The model they are using is not an in ear set, it's over the ear with a mic attached.
 
Thread starter Similar threads Forum Replies Date
B Audio 0
_saltyz Audio 0
Abhishukla Audio 2
omaromarica Audio 1
HemoTalon Audio 0
Godwin123321 Audio 0
G Audio 4
N Audio 1
Xarmen Karshov Audio 5
dinkleberg2 Audio 0
DreadPirateRocco Audio 0
DawSHaa Audio 0
B Audio 4
Behemothxp Audio 3
B Audio 2
K Audio 1
P Audio 8
C Audio 6
I Audio 4
B Audio 3

ASK THE COMMUNITY