MTP USB Device - Unable to see the disk in My Computer

johnymst

Honorable
Dec 21, 2012
4
0
10,510
0
Hi Guys,

I have a GoPro Hero 3 Black + and they recently released a new software for the camera.

Since I installed it I am unable to see the disk mounted in my PC.

When I plug the camera in, Windows is saying that it's "Installing device driver software"
It then says "MTP USB Device" and states that it's successfully installed on the PC.

All great however I still cannot see the disk or can't browse the files on my camera.

I tried to access the camera on a Mac and on another Windows 7 computer - no luck.

I also installed some drivers for MTP from the Windows website...

When I go to Start -> Devices and Printers , I can see my GoPro there
When I go to Device Manager, I can see "MTP USB Device"
I don't see it in the Disk Management.

I have two card readers however they seem to struggle with my Micro SD as it's a 64GB SD XC I class. I guess I have cheap card readers that can support only up to 32 or something. Well the GoPro should be visible in My Computer so let's forget about the card readers

Any ideas how to fix this and How will I be able to access the camera?

 
G

Guest

Guest
Hmmmmmmm. Is there an option on the Go Pro to change it from MTP to USB or Mass Storage?
 
G

Guest

Guest
I just found an article here on the forums where a user was having the same issue. Go to services.msc and make sure these options are set, then restart.

"The problem was with a SERVICES entry; WUDFSVC (Windows Driver Foundation - User-mode Driver Framework) which should be running all the time and set as Automatic start....it wasn't! In the event I had to modify the registry entries for WUDFSVC (I think I had three) and find the START mode entry and modify them to (2) (automatic). They had got set to (3) (manual). Since doing this the system is working fine again."
 

hamzeh2459

Estimable
Jul 29, 2015
1
0
4,510
0
Hello
You have your camera firmware to version 2.0 back
I did the camera work properly
You will not lose any of your camera's capabilities with this solution


 

SteviedWeSolveIT

Commendable
Mar 1, 2016
1
0
1,510
0
This was also bothering me for a while on a macbook running Windows 7.

My gopro would show up as an MTP USB Device and would be discovered and disconnected and repeat this every few seconds.

My solution: Go to Device manager and View | 'Show Hidden Devices'
View 'devices by connection type'
First look under Generic USB Hub to see if any devices under there could conflict and disable each one individually then try the gopro each time.
If that doesn't do it, look at the drivers further down with the little yellow cog e.g. Bitlocker Driver but look for something that mentions USB.
In my Case it was the Citrix USB Monitor Driver. I have to disable that temporarily and I can now see my GoPro as a normal Drive. :)

 

SidFace

Prominent
Jun 22, 2017
1
0
510
0


That worked for me (thanks) but I still had "no files to import" in GoPro Quick. I found that running the program as administrator fixed this second issue

 
Thread starter Similar threads Forum Replies Date
A Digital Cameras 1
M Digital Cameras 6
P Digital Cameras 7
T Digital Cameras 3
B Digital Cameras 1
G Digital Cameras 3
S Digital Cameras 1
G Digital Cameras 0
G Digital Cameras 0
W Digital Cameras 11
A Digital Cameras 1
patrick47018 Digital Cameras 6
C Digital Cameras 1
R Digital Cameras 1
O Digital Cameras 4
S Digital Cameras 5
R Digital Cameras 1
A Digital Cameras 3
T Digital Cameras 1
W Digital Cameras 4

ASK THE COMMUNITY