My autofocus on Canon 40D doesn't work

tonysenior

Honorable
May 29, 2012
1
0
10,510
0
Hi,

When I use the auto focus mode it seems to work, but when I change it to any other mode, macro, portrait, it doesn't. Help, please.
If unable to help online can you recommend a reliable, reasonable shop that can fix it? Thanks.
 

pdxalex

Honorable
Apr 25, 2012
23
0
10,570
2
Hello. It may be a lens issue, rather than body... have you tried it with another lens? If you have, try cleaning the contacts and make sure it's not down to merely overlooking something, such as focus point selection.

If you've verified it's not down to settings or a lens issue, I would send it in to one of Canon's service centers. They're great to deal with and have an excellent reputation.

I've only dealt with their facility in Irvine, CA... give them a call beforehand to explain the issue.
866-510-1335
Reviews of the service center:
http://www.yelp.com/biz/canon-factory-service-center-irvine

Alternatively, if you're not on the West Coast you can find a facility closer to you:
http://www.usa.canon.com/cusa/support/consumer/eos_slr_camera_systems/eos_digital_slr_cameras/eos_40d?pageKeyCode=25
 
Thread starter Similar threads Forum Replies Date
L Digital Cameras 0
L Digital Cameras 0
Bdubb11 Digital Cameras 1
H Digital Cameras 1
H Digital Cameras 1
zilexxxx Digital Cameras 0
L Digital Cameras 1
tyflikw Digital Cameras 2
P Digital Cameras 1
S Digital Cameras 1
O Digital Cameras 2
M Digital Cameras 7
A Digital Cameras 3
anil_robo Digital Cameras 9
D Digital Cameras 1
E Digital Cameras 1
G Digital Cameras 3
C Digital Cameras 3
E Digital Cameras 5
G Digital Cameras 45

ASK THE COMMUNITY