My new Lenovo Legion Y520 is slow

Tiguh

Estimable
Jan 1, 2015
2
0
4,510
0
Hi! I just got a new laptop. It's a Lenovo Legion Y520 gaming laptop but it is pretty slow :( sometimes it would take 5 - 10 seconds to open a folder or some settings. Switching though tabs on google chrome is a pain in the ass too and sometime would not respond too :( can someone help me please? Thanks

Specs:

7th gen i7 7700Hq, 8gb ram, Nvidia GTX 1050ti, 1tb hdd
 
Sounds like you may have stuff starting up and running in the background that is using resources. You can check in "Start" and then search for "msconfig" (without the quotes) and then click to open that name in the list. Then go to that window's "Startup" tab and check what is auto starting.

IMPORTANT NOTE: Do not unchecking anything that the system needs to run. So if you don't know what it is, look it up but don't uncheck it.

Once you are done, apply the changes and reboot.
 
Sounds like you may have stuff starting up and running in the background that is using resources. You can check in "Start" and then search for "msconfig" (without the quotes) and then click to open that name in the list. Then go to that window's "Startup" tab and check what is auto starting.

IMPORTANT NOTE: Do not unchecking anything that the system needs to run. So if you don't know what it is, look it up but don't uncheck it.

Once you are done, apply the changes and reboot.
 
Thread starter Similar threads Forum Replies Date
RoeMyCruise Laptop Tech Support 1
S Laptop Tech Support 0
N Laptop Tech Support 2
E Laptop Tech Support 3
B Laptop Tech Support 0
ionutdragos Laptop Tech Support 1
Sandis2003 Laptop Tech Support 0
Arom_pd Laptop Tech Support 2
A Laptop Tech Support 1
P Laptop Tech Support 7
L Laptop Tech Support 1
F Laptop Tech Support 1
A Laptop Tech Support 1
B Laptop Tech Support 3
P Laptop Tech Support 1
O Laptop Tech Support 2
M Laptop Tech Support 15
V Laptop Tech Support 1
M Laptop Tech Support 1
N Laptop Tech Support 2

ASK THE COMMUNITY

TRENDING THREADS