Need help with Sony Vegas Pro 12 and PowerDirector 12 editing H.264 codec!

nate vongrimm

Honorable
Jul 29, 2012
8
0
10,520
1
I recently started using a new codec with Bandicam to record my PC.
I moved from the MPEG-1 codec to the H.264 codec.
Ever since then, Both Sony Vegas and PowerDirector 12 have been throwing fits at me.
Sony Vegas barely runs preview over 1fps and slightly lags on the timeline and PowerDirector lags like hell when I do the simplest thing on the timeline (often causing crashes) yet plays the preview just fine.
My system isn't exactly a powerhouse but it isn't terrible either.

System Specs:
CPU: AMD Phenom II x4 3.4GHz
GPU: Sapphire R9 290 4GB
RAM: 16GB (4x4GB) Corsair Vengeance
HDD: Seagate 1TB 7200RPM
SSD: OCZ 60GB

Both programs are installed on my HDD and the footage is on my SSD.
My system should have plenty of power to handle both video editors editing H.264 footage.
What could possibly be the problem?
 

kenrivers

Splendid
Moderator
How much space do you have free on the SSD? Are you exporting the footage to the SSD or the HDD? If you are trying to render to the SSD that could be part of the problem since your source files are there as well.
 

nate vongrimm

Honorable
Jul 29, 2012
8
0
10,520
1


It's not the rendering I'm having issues with. It's the editing of H.264 codec videos.
My system should be able to handle the decoding of H.264 clips in video editors with minor lag but it struggles way too much.
For now, I have had to adapt to Proxy video editing. Not ideal but it gets the job done, At least until I can figure out what is going on.
 

kenrivers

Splendid
Moderator


Thank you, I should have read your post more carefully. What settings are you using in Bandicam? This link - http://www.bandicam.com/support/tips/sony-vegas/ - gives the best settings for use with Vegas.
 

nate vongrimm

Honorable
Jul 29, 2012
8
0
10,520
1


I'm using the H.264 AMD APP codec. Using almost the exact same settings as they have on that page. The only thing I have changed is the Keyframe interval from 1 to 150. That might be the reason but setting it to 1 means a 30 minute clip is over 25GB and that is just too big.
 

nate vongrimm

Honorable
Jul 29, 2012
8
0
10,520
1


I haven't tried that yet. I shall give that a try and see if it helps.
 
Thread starter Similar threads Forum Replies Date
A Apps General Discussion 0
G Apps General Discussion 3
Z Apps General Discussion 1
PepeTheDog Apps General Discussion 1
F Apps General Discussion 0
V Apps General Discussion 1
J Apps General Discussion 0
R Apps General Discussion 4
Y Apps General Discussion 1
H Apps General Discussion 0
P Apps General Discussion 4
M Apps General Discussion 0
B Apps General Discussion 0
P Apps General Discussion 1
C Apps General Discussion 1
D Apps General Discussion 2
R Apps General Discussion 1
T Apps General Discussion 1
M Apps General Discussion 2
K Apps General Discussion 1

Similar threads


ASK THE COMMUNITY