ntoskrnl.exe spiking the gpu to 100% and making games freeze.

Apr 14, 2018
7
0
20
1
Hello. I bought an asus rog strix GL503vd. During gaming, and sometimes on idle, my pc freezes for like 1-4 seconds. I downloaded Intel extreme tuning utility and also watched task manager to see which processes freeze my laptop. In IETU i noticed that during those lag spikes, my CPU utility jumps to 90-100%, but in task manager, ,,System'' process pops out and it eats 100% gpu. When I opened the file location it highlighted the ntoskrnl.exe. I tried running the Dism /Online /Cleanup-Image /RestoreHealth command but it didint help. Maybe the system is eating my intel graphic card ? Thanks for help.
 
Apr 14, 2018
7
0
20
1
Hey! For anybody in the future, having the same problem, I found a solution that I hope will work for You. First, make sure it's not throttling. Asus gl503VD requires free space under the laptop too, so make sure to do that. I myself just put 2 books on two sides of the laptop so it has free space under it, not only around it. Now the second part : disable windows auto driver updates. Then go to asus forum and download GPU and Chipset drivers for your laptop. Then just simply install them. It fixed it for me. Also 1 thing worth noting is that windows likes to change your drivers when it updates so make sure your drivers are always the ones from official asus site. Cheers.
 
Apr 14, 2018
7
0
20
1
Gtx 1050 4GB
i5 7300Q
8GB ram
I have an HDD and SSD. Windows is installed on SSD.
Yeah the system process in task manager usually takes 0.0-0.2% gpu. But when the game/windows freezes it jumps up to 100%. Then it goes back to 0.2% again. When I googled this problem, most people had the same problem, but it lagged the CPU or Memory, not GPU : / . The solutions that I found didint work.

https://superuser.com/questions/1310105/system-process-using-100-gpu/1314355#1314355 This guy has same problems as I do
 
Apr 14, 2018
7
0
20
1
Intel driver is 22.20.16.4815
Nvidia driver is 23.21.13.9135
I allready reinstalled drivers many times. I used both, the recommended by Asus, and the latest drivers. Also windows reinstall didin't help.
 

kookie3010

Honorable
Sep 3, 2013
806
0
12,010
168


which version of windows are u currently on?
 
Apr 17, 2018
2
0
10
0
I have the same model as you and am getting the same thing. But mine has a 7th gen i7 and gtx 1050. Windows installed on SSD and has an HDD too. I tried changing it to run on CPU instead of GPU to see if that would do anything but nothing has changed. I checked all my drivers for updates and all also. I've only had this laptop for a few weeks and love it besides this issue.

One thing I'd like to know is if you have Norton installed on your computer?
 
Apr 14, 2018
7
0
20
1
Nope, I don't have Norton installed. Also some screenshots https://i.imgur.com/IVqyw2L.png https://i.imgur.com/xaN17xp.png . This is how it looks during gaming, sometimes I can have an 1 hour gaming session without a freeze, and sometimes I'll get them every 10 minutes. It's completly random, it sometimes freezes on idle too.
 
Apr 17, 2018
2
0
10
0
One thing I just tried was going to Task Manager and finding "system" under Processes. Right click it and click "Open File Location". Right click the ntoskrnl.exe and go to "run with graphics processor" and choose NVIDIA.

Then go to the control panel and click on the NVIDIA Control Panel. Click "Manage 3D Settings", then click the "add" button and go to your system32 folder and find ntoskrnl.exe and choose it. Then click the drop down menu 2 and click for it to run on NVIDIA graphics. This seems to have worked for me so far. Hopefully this will continue to work because those random lag spikes are annoying. Good Luck!
 
Apr 14, 2018
7
0
20
1



Sadly It doesn't work for me. I even switched all default programs to run on GTX 1050 but that didin't work either :/. Thanks for help tho! : )

 
Apr 14, 2018
7
0
20
1
Hey! For anybody in the future, having the same problem, I found a solution that I hope will work for You. First, make sure it's not throttling. Asus gl503VD requires free space under the laptop too, so make sure to do that. I myself just put 2 books on two sides of the laptop so it has free space under it, not only around it. Now the second part : disable windows auto driver updates. Then go to asus forum and download GPU and Chipset drivers for your laptop. Then just simply install them. It fixed it for me. Also 1 thing worth noting is that windows likes to change your drivers when it updates so make sure your drivers are always the ones from official asus site. Cheers.
 
Thread starter Similar threads Forum Replies Date
kittychloe Laptop Tech Support 1
W Laptop Tech Support 1
A Laptop Tech Support 5
W Laptop Tech Support 3
H Laptop Tech Support 6
R Laptop Tech Support 17
F Laptop Tech Support 2
A Laptop Tech Support 1
H Laptop Tech Support 1
T Laptop Tech Support 4
G Laptop Tech Support 1
I Laptop Tech Support 1
S Laptop Tech Support 7
F Laptop Tech Support 1
J Laptop Tech Support 6
D Laptop Tech Support 1
1 Laptop Tech Support 16
S Laptop Tech Support 1
G Laptop Tech Support 1
G Laptop Tech Support 1

ASK THE COMMUNITY