Problem with shortcut-buttons

Remi Rudi

Estimable
Jun 11, 2015
2
0
4,510
0
I have a BIG problem with my one year old Asus G750J laptop keyboard. Whenever i press ctrl, tab shift or alt it stays on until another button is pressed. This is a very big problem when i play games. It happens whenever i press one of the four buttons. Ex: when i hit shift, I can wait as long as i like before pressing a letter. When the letter is pressed it pops up a capital letter without even pressing shift (and no i do not use caps lock....). This problem makes it impossible to actually play a game with the keyboard. It is probably a setting that i've pressed, but i do not know which. i also tried to run CCleaner, but it came up as nothing wrong, so i do not think it is a problem with the software.
Imagine skyrim or any rpg game where shift is sprint, and ctrl is crouch. If i just tap shift, and then tap ctrl, the player will crouch (without holding the ctrl button), and when i move forewards it sprints... the laptop think that both is pressed even if none of them are! Please help, this is pretty much ruining my gaming experience :(
 

viveknayyar007

Honorable
Apr 25, 2013
1,003
0
12,210
133
Hello Remi Rudi

It seems you have accidentally turned on the Sticky Keys or Filter Keys or both on your operating system.

You can resolve the problem by following the steps below:

> Go to Control Panel > Ease of Access > Ease of Access Center.

> Under the Explore all settings section, click the Make the keyboard easier to use option.

> Under the Make it easier to type section, if checked, uncheck the Turn on Sticky Keys and Turn on Filter Keys checkboxes.

> Click Apply from the bottom to save the changes.

> To avoid any such thing in future, click the Set up Sticky Keys option present under the Turn on Sticky Keys category and uncheck the Turn on Sticky Keys when SHIFT is pressed five times checkbox.

> Click OK.

> Back on the previous window, click the Set up Filter Keys option under the Turn on Filter Keys category and uncheck the Turn on Filter Keys when right SHIFT is pressed five times checkbox.

> Click OK to save the changes.

> Close the opened windows and try the new keyboard settings.

Let me know if this helped. :)
 

viveknayyar007

Honorable
Apr 25, 2013
1,003
0
12,210
133
Hello Remi Rudi

It seems you have accidentally turned on the Sticky Keys or Filter Keys or both on your operating system.

You can resolve the problem by following the steps below:

> Go to Control Panel > Ease of Access > Ease of Access Center.

> Under the Explore all settings section, click the Make the keyboard easier to use option.

> Under the Make it easier to type section, if checked, uncheck the Turn on Sticky Keys and Turn on Filter Keys checkboxes.

> Click Apply from the bottom to save the changes.

> To avoid any such thing in future, click the Set up Sticky Keys option present under the Turn on Sticky Keys category and uncheck the Turn on Sticky Keys when SHIFT is pressed five times checkbox.

> Click OK.

> Back on the previous window, click the Set up Filter Keys option under the Turn on Filter Keys category and uncheck the Turn on Filter Keys when right SHIFT is pressed five times checkbox.

> Click OK to save the changes.

> Close the opened windows and try the new keyboard settings.

Let me know if this helped. :)
 
Thread starter Similar threads Forum Replies Date
P Laptop Tech Support 3
saurabhaggarwal Laptop Tech Support 3
aminalias23 Laptop Tech Support 2
S Laptop Tech Support 2
M Laptop Tech Support 1
S Laptop Tech Support 0
S Laptop Tech Support 1
RegisZDB Laptop Tech Support 1
A Laptop Tech Support 0
A Laptop Tech Support 1
C Laptop Tech Support 5
lluia Laptop Tech Support 0
raintop Laptop Tech Support 2
M Laptop Tech Support 4
A Laptop Tech Support 14
M Laptop Tech Support 1
Aizazm Laptop Tech Support 4
K Laptop Tech Support 0
K Laptop Tech Support 4
C Laptop Tech Support 1

ASK THE COMMUNITY