Sennheiser G4me zero bad mic quality.

Aug 10, 2018
4
0
10
0
i just got my new pair of G4me zero's, and the sound quality is amazing both music and ingame, but there is no difference in microphone quality, everyone say they sound the same as my old g430 maybe worse because sometimes there are hissing noises.

i dont use an amp or anything just a 3.5mm jack stright to my Motherboard.

i dont mind getting an amp or somthing but i dont understand why does the mic sound bad when the sound itself is top notch.

Any help is welcome and thank you :D
 

RARRAF

Distinguished
Jul 22, 2007
154
0
18,710
36
well it could be your microphone that is not very good or the motherboard sound card is not good or the drivers for the sound card are old and out of date try updating them.
 
Aug 10, 2018
4
0
10
0


Hey!, thank you for answering, i did update the drivers and there was no change (even though they werent updated since 2016),
and as for the mic the G4me zero mic is known to be the best mic in gaming headset and it should be alot better than my old headset mic.

as for my motherboard i do belive the problem lays there but i would imagine it would effect audio quality as well wouldnt it ?.
 

RARRAF

Distinguished
Jul 22, 2007
154
0
18,710
36
I am not really to up on sound stuff but if it is that big an issue maybe you should think about getting a sound card. As long as you have space for the card I know when I had a sound blaster card in one of my machine's the sound is top quality against the onboard stuff is amazing. But then I do not know what motherboard we are talking about. But I would have a look in your bios as soon as machine boots hammer "DEL" key and have a look at anything related to sound.