"something went wrong while trying to turn on spatial sound" Dolby Atmos

Status
Not open for further replies.

bvanmanen81

Prominent
Dec 13, 2017
5
0
510
0
Hello,

I have a dolby atmos setup at my pc. I got a yahama rx-v583 with 2 front speakers, 2 surround speakers and 2 height speakers. I have this connected to my pc with windows 10 1809 over hdmi. I have installed the Dolby Acces driver. When I try to enable the dolby atmos for home theater spatial sound, I got the message:"something went wrong while trying to turn on spatial sound" and it turns back to off. Windows sonic for headphones does work. I already tried reinstalling the realtek drivers and even my graphics card drivers(Nvidia rtx 2070).
What can I do to get this to work.

Thanks.

 

drivinfast247

Proper
May 29, 2018
134
0
160
20
At minimum you should have 3 front speakers (1L, 1R and center) 2 rear(L&R) and 2 height. Did you go through and set up the Atmos on receiver? Are you using HDMI out from GPU to receiver?
 

bvanmanen81

Prominent
Dec 13, 2017
5
0
510
0
I don't have a center speaker. It isn't nesscery for me as my two front speakers are on my desk, so they are close to each other. My recaiver is atmos compatible. With an other pc it is possible to sellect dolbt atmos spatial sound on this receiver, I tried this. The Hdmi is connected trought my gpu(gigabyte rtx 2070 gaming oc) my motherboard is a gigabyte x470 gaming ultra. cpu: amd ryzen 2700x. I Tried reinstalling the realtek drivers and nvidia drivers. I also tried older realtek drivers but it didn't help. I have 2 monitors. a 2k and a full hd. the 2k is connected with displayport and it is my primary monitor. the full hd is with hdmi and connected to my stereo.
 

bvanmanen81

Prominent
Dec 13, 2017
5
0
510
0

yes, of course I did. I said that I reinstalled the graphics card drivers
 

Kunal Mahajan

Honorable
Mar 17, 2013
1
0
10,510
0





I have a similar problem as op (Windows 10 to Dolby Atmos receiver 7.1 speakers via hdmi)
Thought I'd some context that might help. I am able to right click the sound icon in notification bar and set system to 7.1 audio (pic) , but when I click "Dolby Atmos for home theater" system loads for a second but settings don't change. Also have original error message as op

 
Dec 29, 2018
1
0
10
0
I have the same exact problem. Nvidia 970, audio via hdmi to Denon receiver. Until 1809, I could select Atmos for Home Theater. Now I get the "something went wrong" message and it remains on 7.1. I've reinstalled all the drivers I can think of.
 

oliveru

Estimable
Feb 2, 2015
3
0
4,510
0


Has someone found a solution? Same problem here, reinstalled Windows twice because of this. Works 1-2 weeks and then suddenly I can't select it anymore. Downloaded Atmos videos work, receiver gets Atmos sound, but I can't enable it anymore in Windows??? That's so annoying.
 

Ralston18

Dignified
Moderator
If the audio works for 1-2 weeks then there must be some other factor(s) involved. A "perfect storm" so to speak of things that occur frequently enough perhaps in some combination, to disrupt the audio.

When the problem occurs check Reliability History/Manager and Event Viewer for error codes, warnings, or even informational events that happen just before or at the time of failure/problem.

A backup, a virus scan, some app "phoning home", a power saver, an update of some sort. Any event or occurrence that can be associated with or corresponds to the failures is important.





 

oliveru

Estimable
Feb 2, 2015
3
0
4,510
0


Thanks for this idea - didn't know the tools you described. You are right, there must be "something" but Windows Update was days ago, audio NVidia drivers 1 week ago and I didn't install anything. It was a fresh system 1-2 weeks old, only some games installed, nothing crazy, Virus scanner on board.

But: I found a (temporary) solution in another forum where lots of people have this error. One suggested to go to device manager, to the Audio driver (in my case Nvidia High Definition -> connected to receiver), "update drivers" > "choose local" and select the other one from the list. I had 2 entries, NVidia High Definition, and only High Definition. I selected the last one, ignored the warning message (wrong driver) and now I can select Dolby Atmos for Home theater again. For some others that did not work, but for me Windows is kind enough to be able to select it again. That's bizarre.
 

oliveru

Estimable
Feb 2, 2015
3
0
4,510
0


Yeah and now even with this "trick" it happened again and I can't get it working. Since I did this trick I had Atmos sound. That's so stupid.
 
Status
Not open for further replies.
Thread starter Similar threads Forum Replies Date
Captain Kino Audio 0
E Audio 1
D Audio 8
M Audio 1
B Audio 3
R Audio 1
L Audio 3
B Audio 2
_Bata_ Audio 2
M Audio 1
H Audio 3
A Audio 1
Z Audio 4
J Audio 2
B Audio 3
B Audio 2
E Audio 9
S Audio 2
T Audio 4
T Audio 5

ASK THE COMMUNITY