Sony VGN-CS21S hard disk drive

TimGS

Estimable
Apr 17, 2014
2
0
4,510
0
Hello guys, I have a problem with installing a new hard disk drive on my sony vaio VGN-CS21S. The old drive had many bad sectors so I decided to replace it.

old drive: Hitachi 5K320-320 HTS543232L9SA00 5400 RPM (with Windows 7 installed)
new one: HGST Z5K500-500 HTS545050A7E380 5400 RPM

the new drive is of the right proportions and it fits right in. The problem is that the bios does not detect the new hdd (the old one is detected) so I cannot proceed any further with the installation of operating systems. My bios version is R1080Q2 and its kinda minimal...

In the sony drivers and downloads section http://www.sony.co.uk/support/en/content/cnt-dwnl/VGN-CS21S/list#os1 there is no available download for a Bios update, except a Windows Vista exe (that I guess cannot be used to flash my bios...)

Any ideas?

Thanks in advance
 

TimGS

Estimable
Apr 17, 2014
2
0
4,510
0
ok, problem solved. It was loose slot thingie (little bit damaged case), so I used some tape and all works fine.
 
Thread starter Similar threads Forum Replies Date
M Laptop Tech Support 5
N Laptop Tech Support 1
Djimsy1993 Laptop Tech Support 0
J Laptop Tech Support 1
J Laptop Tech Support 1
OhGod Laptop Tech Support 0
J Laptop Tech Support 0
Mvnch Laptop Tech Support 0
OhGod Laptop Tech Support 0
A Laptop Tech Support 0
M Laptop Tech Support 0
I Laptop Tech Support 0
G Laptop Tech Support 1
M Laptop Tech Support 13
A Laptop Tech Support 0
M Laptop Tech Support 0
G Laptop Tech Support 0
E Laptop Tech Support 0
C Laptop Tech Support 7
Thor-azine Laptop Tech Support 2

ASK THE COMMUNITY