Question Thunderbolt to USB-C Printing Error [MacBook Pro]

Oct 9, 2019
1
0
10
0
Hello Community!


I recently acquired the new MacBook Pro (I've been using Apple for many years now and am accustomed to how they work, but this new MacBook I just got is the 2019 version, which means... Thunderbolt Ports.


When purchasing I took into consideration that due to my line of work and me still being a college student I'd need to print documents and files, which is why I also bought a Thunderbolt to USB-C Adapter.


Upon arrival back home, installation and configuration of my computer and so on, I faced an error that I have looked for everywhere but can't seem to find. This error is as follows:

Whenever I attempt to print a document in an Epson Printer (I have tried with two models so far, Epson T42WD and Epson ET-4500 series) with the adapter, it leads to the printer downloading its driver.

All's normal and good so far, I install the driver from connecting the printer through USB (my computer is able to recognize the printer and download the software required, for both cases), but when I actually attempt to print the Epson software opens. The issue is that it gets stuck on the status: "Ready to print".

This has happened twice, on both printers already. I have tried installing the drivers manually (through the Epson software), and directly through the printer itself, but to no results.

If anyone has any clue what could be done to solve this or find a work-around to it please do let me know. In the meantime, I'm dragging around my old Macbook Pro (2014 model), which works just fine with all printers.

Additionally, if anyone would require any more information please let me know, again, thanks for the help.
 

ASK THE COMMUNITY