toshiba satellite c75d-b keyboard and mouse stopped working

The following is for the attached keyboard and touchpad.

NOTE: If you need to type in a password to even get into Windows to do the following, make sure you attached an external keyboard first, to get past the password. Then disconnect the external keyboard and try the following...

1. Uninstall the keyboard driver.
2. Reboot the computer (without reinstalling the driver).
3. When it restarts, it should reinstall the driver on its own.

If this doesn't work, you may wish to try connecting/reconnecting an external keyboard and see if it works fine. If it does, then it could be the keys themselves that are the issue.

You may also want to try updating the Synaptics Driver if the above doesn't help.


Assuming you mean the touchpad (as most laptops don't use a mouse)...

Try the following and see if it fixes it...

1. Go into "Control Panel".
2. Click "Hardware and Sound".
3. Now click "Mouse and Touchpad".
4. Now go to "Additional mouse options".
5. The Mouse Properties window will open. In here click on your device.
6. Make sure your device is set to enabled. If it isn't then click "Enable Device".
7. Exit both that screen and "Control Panel".

Also, you might want to check for updates to your drivers, including the Synaptics drivers.

If this does not help, and an external mouse works fine, then it may well be a hardware issue.
 
May 13, 2018
3
0
10
0
Thanks for your help but I have tried all of the above and still nothing...
I get this message for the touchpad in the device manager/device status window.:

This device cannot start. (Code 10)
{Device Timeout}
The specified I/O operation on %hs was not completed before the time-out period expired.

the keyboard status says the device is working properly

but neither device is active
I can't even use the Fn-f5 key to activate the touchpad

any other suggestions?

thanks
 
May 13, 2018
3
0
10
0
Also: these three items do not exist in my control panel

2. Click "Hardware and Sound".
3. Now click "Mouse and Touchpad".
4. Now go to "Additional mouse options".