Toshiba satellite m840 power light on but not starting up

weijieeeeee

Prominent
Jul 25, 2017
1
0
510
0
I have a toshiba satellite m840. When it is switched on, power indicator lights up, the fan starts spinning after 10 seconds and stops spinning after a while. Screen is black all the while. Power indicator stays lit and laptop stops responding.

It is worthwhile to note that in normal operation the wireless connection indicator which is a orange light lights up, but it no longer lights up now.

My laptop had some graphics issue (the screen shows vertical green bars) and has been operating with the display driver turned off for about 2 months because the laptop is unusable when the display driver is turned on.
 
Try this...

1. Turn the laptop off (not sleep or hibernate but off).
2. Connect an external monitor to the laptop.
3. Turn on the external monitor.
4. Turn on the laptop.

NOTE: You may have to press an "external monitor" button. Could be the f4 button or a button with two monitors on it, for the external monitor to work.

If you can see fine on the external monitor, then your attached display, or the ribbon cable that connects it, are your problem.

If you can't see on the external monitor at all, or the problem occurs on the external monitor as well, then it is probably the graphics card/GPU that is the problem, which may require the motherboard be replaced.
 
Thread starter Similar threads Forum Replies Date
C Laptop Tech Support 2
W Laptop Tech Support 5
T Laptop Tech Support 1
B Laptop Tech Support 1
contactfina Laptop Tech Support 2
G Laptop Tech Support 1
A Laptop Tech Support 1
G Laptop Tech Support 4
C Laptop Tech Support 1
J Laptop Tech Support 1
M Laptop Tech Support 1
C Laptop Tech Support 1
M Laptop Tech Support 1
T Laptop Tech Support 1
canexicans Laptop Tech Support 3
B Laptop Tech Support 1
C Laptop Tech Support 1
B Laptop Tech Support 1
M Laptop Tech Support 1
F Laptop Tech Support 2

Similar threads


ASK THE COMMUNITY