Truecrypt won't do a FDE after reformat

Blyss Sarania

Honorable
Oct 4, 2013
2
0
10,510
0
Okay first of all, please don't say "Truecrypt is dead, not secure" or any of that. I know about the situation, and I am perfectly happy using an application that I've used for years. I don't believe it just suddenly became insecure.

That said, here is my problem.

First, my system:
Gigabyte GA-78-LMT-USB3
AMD FX 6300 @ 4.4Ghz on water cooling
HIS Radeon HD 7870
Kingston HyperX DDR3 1600, 9, 9, 9, 27
Main drive 1 TB (partitioned OS: 200GB; Data: 531GB; Personal: 200GB)
Sub drives 160GB, 80GB
Windows 7 Ultimate X64 (installed on a single partition, i.e. no 100MB "boot partition")
Truecrypt 7.1a

Okay, so that's that. Here is my problem. I had my full disk encrypted with truecrypt before, with this same setup. Same exact setup. However, I decided to do a reformat for various reasons, mainly to partition my drive more sensibly. Since I completely reformatted and partitioned my hard drive, obviously it is no longer encrypted. And now TrueCrypt refuses to encrypt it.

After going through all the setup and doing the pretest, after entering the password at the screen it displays "Booting..." and hangs. If I push ESC instead of entering the PW, it boots straight away. I have tried EVERYTHING I can think of(which I will list in a minute). Truecrypt itself says when you get back in Windows that the most likely cause of this is "choosing an algorithm other than AES" but I am choosing AES so that doesn't help.

As, I said, I had done FDE on this same system before, with the same version of TrueCrypt(7.1a). The only problem I had then was that Truecrypt doesn't like it when Windows has the special 100MB partition it boots from. Once I corrected that, it worked fine. So when I installed this time, I made sure that I took care of that.

I have tried many things. Changing settings in my BIOS(and it is NOT UEFI BTW), disconnecting all drives except the main 1TB, changing which SATA ports I am using, changing from AHCI to IDE and back. I am stumped at this point.

I also tried just encrypting the Windows system partition, instead of the whole drive. That failed in the same way.

I am really frustrated here. I'm really not comfortable leaving my drive unencrypted. My whole life is on this computer, from creative writing to finances. And I don't want to turn to another solution, especially not BitLocker, as I seriously suspect it has backdoors.

Any help would be greatly appreciated!
 

ASK THE COMMUNITY