typing from the keyboard is slow, it can't keep up.

keplenk

Distinguished
Jul 28, 2007
9
0
18,510
0
hi all,

I'm having problems with my laptop when typing. When I type with my normal speed .. 45-50wpm, the keyboard can't keep up! I went to the control panel and adjusted the speed rate of the keyboard to its max speed meaning:

repeat delay: short (dragged to the right most knot)

repeat rate: Fast (right most also)


After doing this step, it kinda fixed the problem, but after a while, it became slow again =(. Sometimes, when I press multiple "a" keys, I stroke 4 but only 2 letters appeared. This is applicable to "ALL" keys, not just "a". I also tried to strike the keys moderately and it still does the same thing. It feels like that the keyboard is having a memory lapse hehe.

Is this a sign of a keylogger installed in my PC? I scanned my PC using Spybot S & D + Ad Aware (freeware version) + Norton AV 2007 and It just showed a bunch of tracker cookies. It's clean already.

This is the specs of my PC:

Sony Vaio VGN-CR140E/B / Core 2 duo T7300 2.0 Ghz / 14.1 WXGA / 2Gb memory / 160gb hard drive
Vista Home Premium x86
External mouse installed
No other external devices installed

Thank you in advance =)
 

kittle

Distinguished
Dec 8, 2005
151
0
18,660
6
check and see if its a windows problem or hardware problem...

Go into your bios screen and use the arrow keys to move around in your menus. if you still get the same delays -- then its a hardware issue, send back for warranty service.

If the delays are gone, then its something in software. it could very well be a keylogger, or other malware-like pgm that Norton cant find (yet). Next try booting in safe mode. open notepad.. check keyboard speed. gone? then its something you load into windows. still there? then its something inside windows.

Follow that pattern & see what shows up.
 

keplenk

Distinguished
Jul 28, 2007
9
0
18,510
0
Thanks for your replies. I went to the BIOS and the problem doesn't happen there. I have Norton Internet Security 207 and I wish I don't have a keylogger installed. I might have to reload everything. Thank you very much.
 

RSIN

Distinguished
Nov 6, 2008
1
0
18,510
0
I WAS HAVING THE SAME PROBLEM AND IT WAS BECAUSE MY BATTERY ON MY LAP TOP WAS SHOT. TO MAKE SURE IT WAS THE BATTERY I REMOVED IT AND TURNED THE COMPUTER ON USING ONLY THE A.C. POWER. IT WORKED GREAT, AND ONCE I'VE PUT THE BATTERY BACK, IN IT WAS BACK TO THE SAME OLD THING AGAIN. I KNEW THE BATTERY WAS SHOT, BECAUSE WHENEVER I UNPLUGGED IT FROM THE WALL IT WILL DIE RIGHT AWAY. IT WORKED FOR ME IT MIGHT WORK FOR YOU. HOPE THIS HELPED
 

frozenlead

Distinguished
Get a Live CD distro of Linux and see if it has the same problems. I think you may be running out of system memory (but with 2GB you must have one bloated OS...then again, it is a Sony..)

Other than that, I'd try reinstalling windows.
 

bhaas

Distinguished
Jan 15, 2009
1
0
18,510
0
I've got a Dell Inspiron with this slow typing problem. I saw that someone else in this thread found out that it was because of a bad battery. Thanks!!! I definitely concur. I removed my battery, and my computer springs to life. We've been having trouble with this battery for the last couple of months in not holding power and not being properly recognized by the computer. Weird stuff. Time for a new battery, I guess.

Thanks for the solution, thread!!! :)
 

jcbaltz

Distinguished
Mar 21, 2009
1
0
18,510
0
Just shut down my Vostro 1000 laptop took out the old battery, and restarted computer.....

Shazam! Keyboard is faster than me again! THANK YOU, THANK YOU, THANKYOU!

JCB
 

Jcoleman81

Distinguished
May 21, 2009
2
0
18,510
0
I decided to call Dell and see about a free battery replacement, they insisted it was a faulty motherboard and offered to replace it for free (it's still under warranty), will let you know what happens...
 
G

Guest

Guest
It was the battery in my case too. After I removed it, the laptop was fast again. However I find it really weird that my Dell Inspiron 1501 battery worked for precisely a year (the period covered by the guarantee) and then went bad.
 

recon2008

Distinguished
May 24, 2009
1
0
18,510
0
This is REALLY weird. I am having the same problem with my Dell 1501 and purchased it BRAND NEW a little over a year ago.I priced the batteries and they are around 165 + tax.This is AWFUL!!Does anyone know if you have to replace with a Dell battery or if you can use another brand.I have seen them on Ebay for as little as 40.00 with a year warranty.

Thanks
 

Briar

Distinguished
Jun 1, 2009
3
0
18,510
0
Something that might be related to think about. I reinstalled WinXP and ran through the drivers. Everytime I installed the ATI graphics driver for my Vostro 1000 the mouse had issues selecting multiple files and the typing rate slowed down. Take off the graphics driver and everything sped up. Install the driver and take out the battery and everything sped up again. Maybe a driver conflict? Or is the load of the 3D acceleration somehow sucking too much from a dead battery and causing some conflict?
 

Briar

Distinguished
Jun 1, 2009
3
0
18,510
0
Ok, others may have found this or posted it elsewhere but I thought I'd enter it here too incase others find this thread. It looks like one of the causes of all of this is a problem with the ATI Hotkey Polling service. In my case shutting it down frees up the keyboard & mouse. The NVidia pollling service may have similar issues. And no, I don't know why taking out the battery fixes this also. Again, an issue with the drivers since at least the Vostro 1000 has an ATI SMB? There was also a problem with the PCMService.exe, but it's a media service that is not installed by default with a clean install.
 

SkiVAIO

Distinguished
Jun 26, 2009
1
0
18,510
0
Just pulled the new battery out of my sony VAIO and the keyboard sprang to life. I believe it is a combination of XP SP3 and the fact that my PCG-FXA59 is nearly 9 years old..Just running out of resources when all the power saving features are loaded up I guess. :)
 

nairb107

Distinguished
Jun 29, 2009
1
0
18,510
0
Same thing was happening to my Dell Inspiron 6000 and it was the dead battery after all. I didn't notice it right away because my external USB keyboard worked fine, but the laptop keyboard could not keep up. I disabled the ATI Poller service and saw no effect. The second I removed the battery the laptop keyboard was up to speed.
 
Thread starter Similar threads Forum Replies Date
R Laptop General Discussion 1
L Laptop General Discussion 5
A Laptop General Discussion 5
E Laptop General Discussion 3
J Laptop General Discussion 1
G Laptop General Discussion 3
K Laptop General Discussion 3
M Laptop General Discussion 1
K Laptop General Discussion 2
C Laptop General Discussion 1
P Laptop General Discussion 1
O Laptop General Discussion 1
S Laptop General Discussion 3
C Laptop General Discussion 4
S Laptop General Discussion 1
H Laptop General Discussion 5
N Laptop General Discussion 1
J Laptop General Discussion 7
A Laptop General Discussion 1
B Laptop General Discussion 1

Similar threads


ASK THE COMMUNITY